Ford Mustang Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
ok, i have a 1997 GT. The thing is that i recently got new spark plugs...hmm...Bousch....there the ones with the four tips on them and ever since my car has been having trouble at take offs. from 1-3 rpms, After that 3 rpms its runs clean. It happens everytime i turn a corner as well. I Feel like i should replace the the plugs with the regular types and maybe that could solve the problem. Then again it might have something to do with a sensor of some sort.?????
Plaese help me...im new to this!!!!!
 
G

·
put the oem Motorcraft plugs in, AGSF-32C's or if you have some mods, AGSF-22C's...those Bosch plugs are a joke:laugh:...
also your problem could be bad or worn-out O2 sensor(s) and again, buy oem Ford/Motorcraft not some parts-store junk....
 
G

·
I've never heard any good stories about the Bosch's. Like Randy said, the stock plugs do just fine. You might also pop the hood and make sure that all the spark plug boots are tight and secure. They can be kind of tricky sometimes when re-installing them. You're probably fine but it never hurts to check. If you have a stock air filter you just need to replace it. If you have an aftermarket like K&N or AEM you need to carefully rinse it in the direction against the air flow (from the inside to the outside. Do it gently with a garden hose or a faucet tap. Once your COMPLETELY dry check it for any remaining debris or dirt. If it looks good and is dry then you'll need to lightly spray it with oil from an aftermarket filter cleaning kit. If you buy a kit it will contain a cleaner spray as well that you can use before you rinse it with water.

The trick is to spray the oil lightly and evenly. If you put too much on you can damage the little wire in the MAF tha reads the air flow.

The cleaning kits are cheap and you can get them at most autoparts stores.

Cheers!
Snack
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top