Ford Mustang Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
i checked my coils they are working perfectly fine. my engine cranks but will not turn on. i had checked my fuel shut off button and flipped it up and back down. nothing is working. the batter is running perfectly fine. I went to autozone and they told me i had to purchase a crankshaft sensor so i did. Me personally not being a car tech i couldn't do this on my own. I tried using the starter spray inside of the cold air intake which seemed to work a bit but the engine still did not turn on. Does anyone have any ideas on what could be going on? also i checked all my fuses and they are all fine.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
i figured out whats wrong now the only issue is how to disable it. the factory alarm has locked my car from turning over. somehow it went off throughout the night. it worked perfectly fine yesterday when i was using it. now it won't turn over. it cranks but wont turn. anyone have any suggestions.
 

·
Registered
Joined
·
53 Posts
is it a factory alarm if not ide suggest going under your dash and pull the fuses in the alarm system and try and start it then
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
well no one could figure it out so i took the car to the local ford dealership. the PCM went out. Not sure how this happened. Got it fixed for 614 dollars and some change. now the lights are messed up. turn signals, brake lights and hazards don't work. none of the fuses have popped so i'm clueless as to whats going on. this has been like this for about 3 months.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top