Ford Mustang Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Whats up mustangers ......been a while since i posted but the last time i was here i had weird problem that was finally fixed thanks to your help.......maybe you guys can help me again........have this 1998 mustang 3.8 when i start car up it runs fine but after about 8 to ten miles car starts to die out at higher rpms (3000 to 4000) the longer i run it the worse it gets until it finally shuts off.........start it right back up and runs fine at idle and up to about 3000 rpms ........then finally dies out again. now i dont have any dtc ...no cel....i have cleaned maf. checked fuel pressure when i first start car and got 29 psi with vac hose on and 40 with it off that seemed a little low from what i been reading but when the car starts to die when you throttle it fuel pressure starts dropping also the worse the car dies the lower the fuel pressure until it dies completely. replaced fpr and no change .......my question is is this a fuel pump issue or could vacuum leaks or something else be the root of my evil.
 

·
Registered
Joined
·
6,859 Posts
checked fuel pressure when i first start car and got 29 psi with vac hose on and 40 with it off that seemed a little low from what i been reading.
FWIIW, that is perfect fuel pressure.

A 1998 is a return style fuel system with a mechanical regulator. So if you have replaced the Fuel pressure regulator and the fuel pressure is still dropping, this is either low voltage to the fuel pump or a bad fuel pump.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
Thanks im gonna do some voltage checks and see what i come up with I just dont want to drop the tank but its looking like thats gonna have to happen.........ill let you know......hey thanks again!!!!!!!!!!!!
 

·
Registered
Joined
·
35 Posts
Discussion Starter #6
Update.............dropped tank this morning.........wow..the biggest wiring hackjob i think i have ever seen.....im surprised (but super glad it didnt happen) the thing hasnt blown up...wires were cut and fed into the tank down beside the fuel module instead of through it and the wire was bare....just terrible ...........tank was filthy and sock was deteriorated so it was needed to be done anyway .....never ceases to amaze me how people FIX things......lol.....thats what you get sometimes when you buy used i guess.......but anyway thanks for the help guys !!!!!!!!!!!!!!!!!!!!!!!
 
1 - 6 of 6 Posts
Top