Ford Mustang Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1 (Edited)
Ok fellas, this is my first post! Hello to everyone. So as you can see I have a 1999 mustang GT with about 87,000 miles on it. I recently have been having problems with sitting at a red light and it just dying. Or putting the clutch in to coast and it dying as well. Well I did some research and read that it could be the idle air control valve or IAC. So I bought one and put it on and now the problem arises that it bogs down when I give it gas and wants to almost die around 2000 2500 rpms. So I am wondering if maybe it could be the Coil on Plug or COPs? I have accumulated quite a bit of mileage so maybe it is time? Does this sound like the culprit? I have had the car tuned proffessionally so its not that. And it recently just started doing this. The idle problem was happening when we first got the car so I guess it was like everyone said a faulty IAC valve, and it would happen especially with the A/C on. So lemme know if you guys have any ideas or if im right with replacing the COPs. And if anything how could I find maybe the bad COPs? How to test them all? I am poor so trying to minimize spending 200 bucks for 8 COPs from accel COPs.

EDIT
forgot to add that if it does die when I am driving, it is a b**** to start. it starts easily when it is cold but if its warmed up then it is so hard to start back up. I have to sometimes sit in the middle of the road for 3-5 mins with my hazards on waiting for it to cool down to start.
 

·
Registered
Joined
·
3,600 Posts
might be a clogged/clogging fuel filter. when's the last time yours was changed?
 

·
Registered
Joined
·
5,089 Posts
i don't think it would be a cop, i've had one go bad before and it had a slight hesitation/stumble to it but i could still drive it and it would never die on me. I would check the fuel filter also since you've swapped out the IAC.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #4
well I changed the fuel filter and I also replaced all spark plugs with NGK spark plugs and also looked at the COPs and got a pretty constant reading from them about 8.32ohms and I guess the manual says they are supposed to be about 5.5ohms so I figure the COPs are fine. However I will probably upgrade to MSD COPs that I have seen which are about 350 for 8 new ones.

Anyways with the new spark plugs and new fuel filter it has been running a lot smoother and hasnt died on me yet. Even did a hot start and didnt have to hold the gas down to start it. It just started right up when it was hot. (hot start refers to temp being in the middle, we drove it for about 15 mins and then took it home and started it when it was hot) so everything seems to be ok. But I still wanna replace the COPs as they are 10 years old.

I saw Summit COPs, Accel COPs, and MSD COPs, any preference?
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top