Ford Mustang Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 92 2.3l lx hatchback and it seems to be shaking like mad. I was driving on the interstate going like 75, when all of a sudden the mph started to drop...i pressed the gas pedal to the floor and it seemed to only gain a few mph back....then i stopped at a toll and when i started to go again it took forever to accelerate...the car sounds like it is missing...sort of like a demolition derby car, so i got it home but every time i stopped at a stop light or whatever i would have to rev the engine and dump the clutch at 4000 rpms and then it would start to go but the rpms would immediately drop to 1500 and took forever to accelerate. I had it running in my garage and the engine was just shaking back and forth making the whole car shake. then when i would pull the throttle cable back it would sound like that demolition derby car again...it seems to have and awful knock too...i cant determine if it is a rod knock or just some other noise...

if anyone has had the same problem or knows what i can do to fix it let me know....i would really appreciate it.

-thanks,
chris
 

·
Registered
Joined
·
4 Posts
turbo pony said:
I have a 92 2.3l lx hatchback and it seems to be shaking like mad. I was driving on the interstate going like 75, when all of a sudden the mph started to drop...i pressed the gas pedal to the floor and it seemed to only gain a few mph back....then i stopped at a toll and when i started to go again it took forever to accelerate...the car sounds like it is missing...sort of like a demolition derby car, so i got it home but every time i stopped at a stop light or whatever i would have to rev the engine and dump the clutch at 4000 rpms and then it would start to go but the rpms would immediately drop to 1500 and took forever to accelerate. I had it running in my garage and the engine was just shaking back and forth making the whole car shake. then when i would pull the throttle cable back it would sound like that demolition derby car again...it seems to have and awful knock too...i cant determine if it is a rod knock or just some other noise...

if anyone has had the same problem or knows what i can do to fix it let me know....i would really appreciate it.

-thanks,
chris
hey i had the simmilar thing happen to me, the first thing that i checked was the compression and found that i had blown the head gasket imbetween the 3 and 4th cyls. the cause of my problem was that it over heated and blew the head gasket. asfter testing the cooling fan and gage i found that the temp sensor and fan were both cooked. hopefully that can help narrow it down for you. if you need to know any more let me know.

Kelvin
 

·
Registered
Joined
·
93 Posts
you could have a blown cylinder. i had a similar, possibly the same problem, but since my car is auto, when i came to a stop the car would just crap out and shut off on me. if its a blown cylinder, just say goodbye to the car. its not worth repairing.... although i had my engine replaced for over 2 grand...

since im in college at the moment, my dad decided to fund the engine replace, and apparently he had the money to replace an engine for 2,000 but not just buy a good condition 5.0 for 1,700. go figure.

i wouldnt recommend getting the engine replaced though. its too much money, when i had mine replaced for 2,000, i got that discounted.
 

·
Registered
Joined
·
69 Posts
ARdoller said:
you could have a blown cylinder... if its a blown cylinder, just say goodbye to the car. its not worth repairing... i wouldnt recommend getting the engine replaced though. its too much money
AHEM!!! A few simple words... if the motor is crapped out as ARdoller says... you CAN pick up a whole 2.3T car and perform the 2.3T swap into it for a lot cheaper than going out and wasting $2000.00 on a brand new motor.

A stock 2.3L N/A motor is good too if you dont want to upgrade... but buy one used from the JY. I am sure you can get one for about $200-$400.

But before you jump the gun on this one... your car is a 92... and unless your car is billowing a cloud of steam out the tailpipe... it MAY just be the MAF or another stupid little thing.

My merkur has a VAF, similar to a MAF in principal... if it is disconected... or if it pops... the car runs like total A$$ and has no power... as well as it WILL practically stall out if you dont rev the s*** out of it with no VAM.

Please check the little stuff before you go out and pull the motor... unless you want to go with the 2.3T... then it can be done regardless of if the motor is blown or not... if you can afford to... :kooky: :kooky: :kooky:
 

·
Registered
Joined
·
93 Posts
its not the motor that costs 2,000, its the cost of labor ontop of that... if he doesnt do it himself.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top