Ford Mustang Forum banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
I just bought my first car, a 1999 Mustang V6 with 75k miles on it. There are two things on it which I am wondering if they are bad. First of all, when I press in the clutch you can hear a sqeaking sound. This mainly happens when it is cold, but I think it always does this. It might even do it alittle when you let it out, but it is not as noticable.
The next problem is that the ABS light does not come on when I start the car. I ran a carfax report and it is supposed to have abs. Maybe its just the light?

If anyone can shed some light on these two things I would appreciate it. I might take it into a garage as well.


Thanks! :laughlitt


Carfax:

Year/Make/Model: 1999 FORD MUSTANG

Body Style: COUPE Engine: 3.8L V6 SFI Fuel: GASOLINE Driveline: REAR WHEEL DRIVE Manufactured in: UNITED STATES Safety Equipment: 4 Wheel ABS Optional, Dual front air bags/active (manual) belts
Standard Equipment: Power Windows, Power Steering, Air Conditioning, AM / FM Cassette, Power Brakes, Tilt Wheel, 6-digit Odometer
 

·
Registered
Joined
·
785 Posts
2 Problems cont'd =

I have not had a standard stick for awhile, but I seem to remember when the "squeeking" noise came when pushing ii and releasing the clutch it was the "throwout bearing" on its last legs. It meant replacing the bearing - and while your at it, the clutch.:sosad:
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top