Ford Mustang Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Since the temp here in nj has gone up quite a bit I've noticed my check coolant light has been coming on once in awhile when the car heats all the way up. So I just put in coolant and added it to the bottom of that line where it says add coolant with the arrown facing down. The car was cold when I did this. Rite when I started it back up the light came on an stayed on. My question is if I drive it and let it reach hot temp will the lite go out? And where to on the reservoir do u fill the coolant? Thanks
 

·
Banned
Joined
·
3,705 Posts
Fill it up about an inch or so from the top.
The float on the sensor gets stuck sometimes. Just stick a screwdriver or any other object you prefer in there and knock it loose.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
I filled it and ran it til it got hot and it did good for an hour then came on when I started it back up. I checked and the coolant was in the middle of the arrow so I'm gonna try that screwdriver thing next. Thanks
 

·
Banned
Joined
·
3,705 Posts
Somebody mentioned on here once that if the coolant mixture isn't the correct 50/50 that the float won't float properly, too.
Also, if you haven't flushed out your coolant in a long while, sediment and gunk can build up, causing the sticking float.
 

·
Registered
Joined
·
7,401 Posts
Happened to me once, I hit the coolant reservoir and it's never come back on again.
 

·
Registered
Joined
·
79 Posts
Worst case if you can't free it up, you'll just have to replace the coolant jug.
 
1 - 6 of 6 Posts
Top