Ford Mustang Forum banner
Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
hi everyone i have just joined the forum and have a question my mustang has a little stumble when ever i accelerate and it has a more serious loping feel whenever i am sitting at a red light with the a/c on and in gear? please if any one has any advice i would really appreciate it.
 

·
Registered
Joined
·
135 Posts
How old is your air filter? Basic tune up and maybe a Seafoam will go a long way..
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
I did a full tune up about 2 months ago and it have a new fender well cai on it. all this happened before i put the intake on i think it may be the maf sensor but i am not sure.
 

·
Registered
Joined
·
6,158 Posts
MAF might be dirty have you cleaned it recently?
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
its been probably 3 or 4 months ago since i have and that was because one morning when i got ready to go to work my car was running horrible i cleaned it then and then it was fine thats what has me thinkin thats the problem
 

·
Registered
Joined
·
135 Posts
Might want to check your plugs too to make sure you havn't fouled one.
Did you pull the battery to reset the computer after the CAI?
You know this already but it's got an A/F issue written all over it.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #7 ·
well i think i came to a conclusion after trying to clean it again. the check engine like came on and i ran it and of course its the maf sensor. Does any one know where i can get some good internal for my v6 it has 198000 miles on it and im planning on a rebuild i was thinking about supersix i have heard there parts are good and i want to do a tma turbo along with the rebuild does anyone have suggestion for gears that i can go ahead and install that would be safe for the car to fun until i get the engine done?
 

·
Registered
Joined
·
485 Posts
This guy seems like a troll.....
 

·
Registered
Joined
·
6,158 Posts
well i think i came to a conclusion after trying to clean it again. the check engine like came on and i ran it and of course its the maf sensor. Does any one know where i can get some good internal for my v6 it has 198000 miles on it and im planning on a rebuild i was thinking about supersix i have heard there parts are good and i want to do a tma turbo along with the rebuild does anyone have suggestion for gears that i can go ahead and install that would be safe for the car to fun until i get the engine done?
i think you should slow down.. youre asking too many questions about too many different topics.. and youll probably never get them all answered
 

·
Registered
Joined
·
485 Posts
^ Which is why i said what i said
 

·
Registered
Joined
·
6,158 Posts

·
Registered
Joined
·
6,158 Posts
so did cleaning it help?
 

·
Registered
Joined
·
6,158 Posts
that doesnt mean the MAF is necessarily bad though wouldnt wanna waste the money on that just and find out the problem is still there..
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #16 ·
I see what your saying but the obd2 reader said it was the maf and i have only had these problems after i cleaned it that one time when it was messing up... im still looking to see what else might be wrong...
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #18 ·
i cant remember the brand name of it but it was maf sensor cleaner and its been about 5 or 6 months since i changed out the fuel filter...
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top