Ford Mustang Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone,
Im new here, and thought i would start asking some questions.
I have been reading alot of forums on how the IAC can make the motor run bad or not idle, on my bullitt i am having a simular problem, but before i fork out the 50 bucks for an IAC i want some fedback on what you guys think.

Some times the motor is really hard to start, i will crank it 3-4 times before it will start, and when it starts, it revs up and holds it for a min or so. this happens randomly, motor warm or cold. Also, the motor surges when it is cold. I can give it about 1/4 throttle and it will act like the traction contol kicks on for a min. After it warms up, it will stop completly. Also, after the motor warms up, it feels like the motor doesnt have any power untill you rev it up (around 3500-4000 rpm). Kind of a surging feeling, like you can feel every rpm wanting to go but not quit making it. I have only had the car for about 5 months. This is my first bullitt, but im not unfamilar with the computer contols on the new cars. All i know about the car this far is that it has a K&N air filter, and flowmaster single chamber mufflers in place of the facory mufflers. There is a BBK sticker under the hood, but i have no idea what is goes with.

im sorry about the mumbling on, but i wanted to spit out all the problems i could think of, in hope it is related. Thanks for your time and info,

Mike
 

·
Registered
Joined
·
1,918 Posts

·
Registered
Joined
·
2,579 Posts
That doesn't sound like an IAC valve. Probably a dirty MAF.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top