Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter · #1 ·
Well I'm guessing the 14X,XXX miles is starting to show.... recently while driving in the mountains at low speed and climbing I noticed the engine temp was climbing...rather quickly...Up to this point I've never had an issue with the temp needle going past the halfway point, ever... this was the first time I've seen it this hot...I cut my drive short and headed home. Got home and flushed the radiator, changed the T-stat(180) and put in new coolant with distilled water... car ran fine and never had an issue again...until today...temps outside was 100 and noticed the A/C air was no longer blowing cold...looked at the engine temp and it was past the halfway(where it usually sits) and was about 3/4 of the way to the red...this was while I was sitting at a red light..Got moving and temps stopped climbing and didn't start to come down until I was almost home...about 3 miles from where the stop light... Did some searching on here and saw someone mentioning to change out the radiator....This is the original radiator and would like to try to cover all cheaper options before I buy a new radiator...saw a mention of changing the temp the fans come on....I have a SCT X3 handheld....can I change the temp that the fans come on with that?? Thanks in advance

This is an Auto tranny if that makes any difference..
 

·
Registered
Joined
·
369 Posts
Sounds like your radiator fan is not working as it should.
 

·
Registered
Joined
·
301 Posts
+1 on the radiator fan! Check to see that it is functioning properly and if not, theres your problem!
 
1 - 3 of 3 Posts
Top