Ford Mustang Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi I would like a little bit of help here, i have a couple different problems with my car right now.
first off when i put the bbk throttle body in, i think i may have messed up the tps because when i am at idle it will rev up just a little bit (like if the ac is on or something), it does this about every minute, doesn't rev up to high but you can tell by the pitch in the exhaust.
also when i had it looked at to inspect it the air temp sensor was off or something, could be from CAI?
I also don't have a chip in it yet either from all the mods i have done i think its about time, i was just waiting to just put in a fuel pressure regulator and some ignition stuff, does anyone know where i can find a fuel pressure regulator for my year model? also what chip would be best?
one more question, has anyone heard about running a 4.2l cam in a 3.8 motor?
 

·
Registered
Joined
·
11,432 Posts
white01stang said:
Hi I would like a little bit of help here, i have a couple different problems with my car right now.
first off when i put the bbk throttle body in, i think i may have messed up the tps because when i am at idle it will rev up just a little bit (like if the ac is on or something), it does this about every minute, doesn't rev up to high but you can tell by the pitch in the exhaust.
also when i had it looked at to inspect it the air temp sensor was off or something, could be from CAI?
I also don't have a chip in it yet either from all the mods i have done i think its about time, i was just waiting to just put in a fuel pressure regulator and some ignition stuff, does anyone know where i can find a fuel pressure regulator for my year model? also what chip would be best?
one more question, has anyone heard about running a 4.2l cam in a 3.8 motor?
No, if the intake sensor is off, your choke will be off.

What kind of CAI did you put in?

the cam doesn't matter so much as the flow. the more radical cam comes from a 94-8 3.8L.

But you're better off going with a custom from Comp Cams, rpm-mustangs.com, supersixmotorsports.com or moranav6racing.com, than a 4.2L OEM cam.
 

·
Registered
Joined
·
11,432 Posts
white01stang said:
Hi I would like a little bit of help here, i have a couple different problems with my car right now.
first off when i put the bbk throttle body in, i think i may have messed up the tps because when i am at idle it will rev up just a little bit (like if the ac is on or something), it does this about every minute, doesn't rev up to high but you can tell by the pitch in the exhaust.
also when i had it looked at to inspect it the air temp sensor was off or something, could be from CAI?
I also don't have a chip in it yet either from all the mods i have done i think its about time, i was just waiting to just put in a fuel pressure regulator and some ignition stuff, does anyone know where i can find a fuel pressure regulator for my year model? also what chip would be best?
one more question, has anyone heard about running a 4.2l cam in a 3.8 motor?
you don't need a chip, necessarily, it may help a bit, but it's hard to say w/o knowing what mass air you're using, the CAI, the diameter of your pipes, etc.

I didn't see your mods. the 70mm BBK unit may be throwing off the intake flow, unless it was port matched.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
im running a 75mm pro-m mass air unit, it was calibrated for the injectors that come with the car. the cai is one off from ebay, standard fender wall cai, im not running the vacuum hose for the oil, bought a breather. mac headers 1 5/8 and pipes are 2 1/2
 

·
Registered
Joined
·
11,432 Posts
white01stang said:
im running a 75mm pro-m mass air unit, it was calibrated for the injectors that come with the car. the cai is one off from ebay, standard fender wall cai, im not running the vacuum hose for the oil, bought a breather. mac headers 1 5/8 and pipes are 2 1/2
yeah, you're gonna need to take care of some issues 1st.

you need to port match your intake ( so you're getting some back wash and idle air on the intake port. Your exhaust is too big, (unless you're running N2O), and your CAI probably isn't working any better than a drop in. None of the metal CAI's do.

you're not going to get much from a programmer or chip, not as much as if you cleaned up the flow on the car.

when you take care of those issues, you'll need a cam to be able to make power above baseline, or at least 1.8 Roller Rockers, to improve the flow to the combustion chambers, and eliminate the dead air.

When you get the cam you will need a programmer or chip, though. but you really should take care of the above issues, or you're not gonna be happy with the results.

There was a guy around here (who shall remain nameless) who tried to run me with the same combination. It wasn't pretty, as he was down by at least 10 ft/lbs down low, and 8 hp from baseline, and even with the relatively minor mods I've done I'm up 15 hp/12 tq (even with the 85,000 miles I had on the car, then). So the spread was 25 hp/20 tq.
 

·
Registered
Joined
·
11,432 Posts
he didn't have gears, though . . .
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
thanks for your help, where would i get my intake port matched, also i have been wanting a new cai, how much was your demolet and where did you get it?
I can't believe that guy lost so much power from the same set up
 

·
Registered
Joined
·
11,432 Posts
white01stang said:
thanks for your help, where would i get my intake port matched, also i have been wanting a new cai, how much was your demolet and where did you get it?
I can't believe that guy lost so much power from the same set up
If you have a dremel, you can do it yourself . . .. Or take it to a machine shop.

Go to yahoo autos, click on customs, and they have a listing of area installer/speed shops.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top