Ford Mustang Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Well I am having the same problem in July 2014 and to add to this, When I turn the head lights on they dont flash, only the running lights.

Noticed this right after I had a little rain fall on the interior. I left the top down and ta daaaa Darn!!!

We had three solid weeks without rain then bang got a little sprinkle

I had a problem before the rain with the after market stereo the front speakers had stopped working but I am pretty sure the two are not related. However, thought of the ground not being good enough so cleaned up the posts on the battery etc.

Didnt work, looking at the possibility of the switch but the headlights are fine. It is the running lights and I am not sure if the circuit even goes trough the switch.

Yeah so Im in Canada eh and we have a short summer to burn the rubber on the stang......

Any idea's???? What is happening???
 

·
Vendor
Joined
·
979 Posts
Well I am having the same problem in July 2014 and to add to this, When I turn the head lights on they dont flash, only the running lights.

Noticed this right after I had a little rain fall on the interior. I left the top down and ta daaaa Darn!!!

We had three solid weeks without rain then bang got a little sprinkle

I had a problem before the rain with the after market stereo the front speakers had stopped working but I am pretty sure the two are not related. However, thought of the ground not being good enough so cleaned up the posts on the battery etc.

Didnt work, looking at the possibility of the switch but the headlights are fine. It is the running lights and I am not sure if the circuit even goes trough the switch.

Yeah so Im in Canada eh and we have a short summer to burn the rubber on the stang......

Any idea's???? What is happening???
Give us a call and we can help you troubleshoot over the phone: (314) 205-3033

Have you checked all of your fuses yet?

Nick C.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
ok when they detailed the car they bumped the amp in the trunk. I guess the switch for high or low ..... so it only played the low.......fixed

Now I am looking at the DRL module or something. Thank you Diode Dynamics I will give you a call
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
thank you DD I managed to get the mechanic kid next door to give me a moment.

the DRL is on the left side close to the front, I had to lay on the ground and stick my head under. found it mounted to the side and had a plug and a few wires coming from it.

I decided to disable it so that I can find the part at my leisure

So we removed the fuse under the steering because he says the bigger ones under the hood has more chance of controlling more than one thing.

He used the owners manual to find the fuses in the fuse box. However the relays and their locations were not in the book.
 
1 - 5 of 5 Posts
Top