Ford Mustang Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hello All,

I have thrown the P0190 Code listed above. I have read all of the posts I could find on this site as well as (shame) other Mustang sites. In my case I get a sudden drop in rpm as if you turned off the ignition(mostly in left slow turns under 30 mph). In additon I have lost my fuel tank guage. When the problem first occurred the guage went to zero and the low fuel indicator came on. This morning when I turned on the ignition the guage came up to read a full tank when by mileage I was down about 9 gallons. I disconnected the plug to the sensor and replugged it in. I pulled and sniffed for fuel at the vacuum port so it appears the diaphram is not corrupted. Neither seem to be the problem. Overall the car runs perfectly except for the occassional drop in rpm described. I could not find any posts for this problem with the associated fuel guage problem. Any help appreciated.
 

·
Registered
Joined
·
190 Posts
there is a bad electrical connection at the fuel module.the pressure sensor is not the problem.it is only detecting the sudden drop in fuel pressure,You are only noticing a drop in rpm.the same it's causing the loosing of the fuel gauge reading.check the fuel tank electrical connector for signs of corrosion or a back up terminal or even melting of the plastic material due to overheating.test the wires with an ohm meter,should be no resistance.(across the connector,i mean.)if nothing is found,drop the tank and replace the complete fuel module.that is the plastic cup that is inside the gas tank and contents the pump,the level sensor and strainer filter.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top