Ford Mustang Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
301 Posts
Discussion Starter #1
I was riding passenger in my friend's 04 cobra and when he put all 13 psi through the engine, white smoke shot up from the passenger's side vent of the hood and when we looked under the hood, it looked like it was coming from the intercooler resorvoir. Is it possible that the cap is just worn out or is the cap just under rated for the set up he has? The coolant only shot out when the car was under high boost.

Its pretty much a pullied cobra with intake, full exhaust and tune pushing 13 psi. Thanks!
 

·
Registered
Joined
·
5,089 Posts
I would just try replacing the cap if it's where it's shooting out. Before i went with an aftermarket one, I had about 15 psi of boost with zero issues. Make sure the clamps are good and hoses look good too.
 

·
Registered
Joined
·
301 Posts
Discussion Starter #3
Ok good, he bought a cap rated at 15 psi so hopefully that was the problem. He had to wait til today to buy the coolant from the dealership so he should know for certain some time this week if that was the problem. Ill tell him to keep an eye on the hoses too! Thank you!!
 

·
Registered
Joined
·
271 Posts
innercoolers/radiators are all pressurized under rpm and heat. even the 16psi or whatever would probably be enough to blow all over everything to spray out. make sure the cap's on tight. might;ve just came loose.. wich is weird. but possible. OR maybe one of your hoses blew
 

·
Registered
Joined
·
301 Posts
Discussion Starter #5
Well it happened again! This time we noticed that the intercooler tank is cracked. Some of the guys on chicagosvt said they had a similar problem where their tanks cracked under high pressure. So it looks like its time to upgrade the tank to aluminum. Anyone here had the same problem?
 
1 - 5 of 5 Posts
Top