Ford Mustang Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
New here to AMF and need some help--ASAP!

I have a 2004 GT, no aftermarket mods, automatic transmission. Is having a weird idle issue. when car has been sitting for awhile (i.e. overnight, while at work all day), turn the car on, put into gear, car tries to idle but it drop and spikes between 400-1000 rpms for about 10 seconds. Acts like it wants to die, but never does. After it wavers for this 10 or so seconds, it levels out and is fine. I have replaced the IAC valve, new spark plugs. Has not been putting out any "codes". Took it to ford dealer and they charged 230 and said I had a missed connection on the #7 coil and they "fixed" the problem. The car is still doing the same thing. Doesn't do it throughout the day, only when its been sitting awhile. No issues driving, seems to have idle stability at stop lights, etc. Any ideas? I am not very versed in car lingo, so please "dumb" it down for me. I can do some things on my own (i.e. the spark plugs, change oil, IAC sensor, etc.). I do not want to shell out another chunk of money if this is something I can figure out. Ford wants me to bring the car back in on Monday (today is Sat.). If anyone can help me out before then, it would be EXTREMELY appreciated.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Ok, so here's what ford came up with. The iac valve I got was "defective". I bought a ford motorcraft brand and installed myself. The issue has somewhat resolved. The car doesn't do the rpm wavering thing as often on a cold start. But, when in park or idling in gear at a stop light the RPMS are still dropping and spiking randomly. The car drives beautifully, aside from this. Also, there is a clicking noise right before the RPMS drop? I read the other forum and it's way too technical for me. Any other ideas?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
And why the fark can't ford figure this crap out? They keep saying they have "fixed" the problem and the car is the same as when I brought it in.
 

·
Registered
Joined
·
2,264 Posts
Any exhaust or vacuum leaks? Have you checked fuel pressure?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
I have no idea how to check for vacuum or exhaust leaks. My knowledge is pretty limited. I don't know how to check fuel pressure either. Are there any step by step for the layman? If it was either of these things wouldn't Ford have been able to diagnose that on either of the two visits my car has made in the last week???
 

·
Registered
Joined
·
2,264 Posts
I highly advise that you find a reputable shop near you. Someone who is knowledgeable and able to figure out your problem. Is there any reputable tuners/shops near you?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
I've never had to take my car in anywhere before. And a fellow mustanger recommended a local ford dealership because he had great experiences with their service dept. I have been less than impressed. I guess in my limited knowledge, I assumed FORD service people would know what they were doing with a ford product.
 

·
Registered
Joined
·
2,264 Posts
Where are you from?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
Lenexa, Kansas.

So, here's the latest. I replaced the IAC with a ford motorcraft IAC and the car seems to be behaving better. The "jumpy" idle on a cold start is gone. But it still is having trouble at stop lights, acts like it wants to die sometimes, but never does. All in all, it seems like its better. Thanks for your help :)
 
1 - 12 of 12 Posts
Top