Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Ok one day i was sitting at a bridge waiting for a boat, my car was in park and then it just turned off, didnt think much of it. A month later it did the same thing but the car was idleing at over a 1000 rpms. Today i was going to the store and the car shut off and I lost all power, steering, and brakes. Turned it on the the engine safemode light came on with the engine light. I got home reset it and took a drive down the road casue the car wouldnt go over 4000rpms and drove like a camry. It ran fine worked great, got home put it in park to see if it would do it again. The car turned off, i turned it back on and then it wouldnt stay on and the idle was bad when i would rev it took a sec. for the car to register, now it runs when ever it feels like it.

So far the long story, but its all stock except the exhaust.
 

·
Registered
Joined
·
11,864 Posts
Ok one day i was sitting at a bridge waiting for a boat, my car was in park and then it just turned off, didnt think much of it. A month later it did the same thing but the car was idleing at over a 1000 rpms. Today i was going to the store and the car shut off and I lost all power, steering, and brakes. Turned it on the the engine safemode light came on with the engine light. I got home reset it and took a drive down the road casue the car wouldnt go over 4000rpms and drove like a camry. It ran fine worked great, got home put it in park to see if it would do it again. The car turned off, i turned it back on and then it wouldnt stay on and the idle was bad when i would rev it took a sec. for the car to register, now it runs when ever it feels like it.

So far the long story, but its all stock except the exhaust.
what yr and how many miles on it? have you changed the fuel filter? do you have warenty? if you have a engine light, you can get the code its throwing with a hand held scanner or at about any parts store for free. that will really help you,,,,maybe :shiny:
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
05, 41563, and just bought a new filter and got the intake thing cleaned a month ago, i think warrenty ended by now but that doesnt matter. Anything i look on it says its the throttle body or the TPS sensor.
 

·
Registered
Joined
·
751 Posts
Does your call stall only when idling? or did it shut off when you were driving?
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top