Ford Mustang Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
766 Posts
Discussion Starter #1
Hi folk. My wife called me at work yesterday and said there is a pallet in my driveway with a couple of big boxes on it, so I guess my Techco supercharger has arrived...Gonna be a busy weekend.

My question is about the gauge panel I am going to install. I have searched the forum and found one source but the pics were small and I could not see what the author did...I am going to install an electric water temp gauge and was wondering if there is a convienient place to tap into the coolant temp for the sending unit. Using an Autometer sport comp gauge along with their vac/boost gauge. A/F gauge sometime in the future when I recover form the initial expense of this project. Thanks GA
 

·
Registered
Joined
·
10,877 Posts
Hi folk. My wife called me at work yesterday and said there is a pallet in my driveway with a couple of big boxes on it, so I guess my Techco supercharger has arrived...Gonna be a busy weekend.

My question is about the gauge panel I am going to install. I have searched the forum and found one source but the pics were small and I could not see what the author did...I am going to install an electric water temp gauge and was wondering if there is a convienient place to tap into the coolant temp for the sending unit. Using an Autometer sport comp gauge along with their vac/boost gauge. A/F gauge sometime in the future when I recover form the initial expense of this project. Thanks GA
Here you go :bigthumbsup
 

Attachments

·
Registered
Joined
·
766 Posts
Discussion Starter #4
Thanks guys, one looks like there is a port already on the thermostat housing. Have to look at mine. The other shows a port somewhere on the motor but does not say where it is..Do you know Travelers? GA
 

·
Premium Member
Joined
·
72,882 Posts
Thanks guys, one looks like there is a port already on the thermostat housing. Have to look at mine. The other shows a port somewhere on the motor but does not say where it is..Do you know Travelers? GA
It's the cylinder head temperature sensor on the passenger side under the intake plenum.
 

·
Registered
Joined
·
519 Posts
I don't know about the Techco, but the replacement crossover that came with the KB has the same plug.. used to help fill the coolant system.. you add to the reservoir with that plug out and when water comes out, you are full.. If your Techco crossover has the same plug, and you are going to put a sensor there, wait until AFTER you have run the engine to temp and gotten all the air out, otherwise you will have to remove the sensor a couple times and it might get scuffed up..
 

·
Registered
Joined
·
766 Posts
Discussion Starter #8
Thanks for the tips....I just got home today and looked thru all the parts that came in the boxes. Looks like a pretty complete kit. The instructions are a package of about 60 or 70 pages with pictures and line by line instruction. I'll have to read thru them and see if they mention anything about a coolant temp sensor....Planning on starting this tomorrow somtime....Got to cut the grass first...Maybe I'll put the Techco on the mower and do 6 acres in about 12 minutes! :bigthumbsup
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top