Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm new to the forums and looking for some help. Glad I found this place so hopefully some of you can help me with my rookie mistakes sense google wasn't much help. I have a 2005 v6 mustang and I have put a lot of work to the outside of my car to give it a more aggressive look than the stock v6. I than tried to give my little v6 engine some more power by getting a BBK CAI and a G-Force performance chip and installing it my self. I followed all the proper instructions and did everything as I was supposed to. After having my new CAI in for about a month I than added my chip. The instructions on the chip said to give it 100 miles before it fully sets into the car's computer. Well it's way past 100 miles and it feels no different. And now my check engine light is on.
Please help.
 

·
Registered
Joined
·
198 Posts
IMO, I'd ditch the chip and get a tune from American Muscle. And maybe even get a new CAI that requires a tune. You will see a HUGE difference.
 

·
Registered
Joined
·
250 Posts
Yea a custom tune from BAMA through AM is probably going to do alot better than that chip, because it is custom to your car, engine, any mods, they take everything into account when programming a tune for you.
EDIT
If I where you, I would sell your chip and CAI, and pick up a combo pack from American Muscle here http://www.americanmuscle.com/05-07-mustang-chips-tuners.html
Way more bang for your buck if you get the tuner and CAI from AM, plus most of the tuners come with 3 preset tunes, and you can always send it back and BAMA will reprogram them accordingly to your mods.
 

·
Registered
Joined
·
915 Posts
It's been a consensus that the BBK requires a tune 80% of the time. Mine threw a code at me when I didn't tune it. I like the BBK, but I'll be upgrading to the JLT soon.
 

·
Registered
Joined
·
777 Posts
Get rid of the "chip" -- all that is doing is a using a resistor to try to trick your MAF. Likely that is also contributing to your CEL, along with the "no tune required" CAI that usually does require a tune.
 

·
Registered
Joined
·
250 Posts
Well the CAI I have right now is from AM but it doesn't require a tune so shouldn't it be okay?
If it says it doesn't need a tune than your fine, but your chip might not be accounting for the CAI which is causing your problem. That's the only reason I am suggesting getting a tuner and CAI in a bundle so you know they will work together.
 
1 - 7 of 7 Posts
Top