Ford Mustang Forum banner
Status
Not open for further replies.
41 - 56 of 56 Posts

·
Registered
Joined
·
5,847 Posts
Hello Bkid,, In trinity, I do not have any custom tune, 91 Octanes Perfomace and 93 Octanes Perfomace, They come installed of factory. I look " Mass Air Table - Ford Gas Vehicles only" in Menu of Trinity, and Only he was asking for his function.
Do you have a Cold AIR intake?
 

·
Registered
Joined
·
5,847 Posts
Yes, K&N,, Trinity have a specific tune for this filter, i try but the same. Thanks for you help BKid.
Check for leaks in the Cold air intake ,under where you can not see sometimes if tightened up to much it will cause a leak. Did you CLean THE MAF sensor with MAF SENOR cleaner?
 

·
Registered
Joined
·
56 Posts
Good Mornig in Spain BKid;-)

Yes, I clean the MAF Sensor.

I don't understand "leaks in the cold air intake", Like, is it verified?, I remember, when all start, to see my mechanic, clean the filter with the air compressor. It is possible, the filter was getting damaged?
 

·
Registered
Joined
·
56 Posts
Hello to all.
Today, I have given myself count, of that the leaks throw more white smoke of the normal thing. One of them, that of the driver, It leaks, waters down, of condensation, before it was not doing it. The whole problem, can of the valve of evaporation?
Thanks.
 

·
Registered
Joined
·
5,847 Posts
Hello to all.
Today, I have given myself count, of that the leaks throw more white smoke of the normal thing. One of them, that of the driver, It leaks, waters down, of condensation, before it was not doing it. The whole problem, can of the valve of evaporation?
Thanks.
Hello,is it cold there this morning? If it is cold, white smoke is not a bad thing at start up. That is just condensation in the pipes.
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #50 ·
Cleaned the MAF again.

Still no better.

Revs up to just over 2000 rpm on startup & then slowly drops to about 1100 rpm before slowly dropping to 800 rpm.

Seems a bit high when it only used to rev up to about 1300 rpm on startup before cleaning the MAF & TB.

Ford say all is good & everything is within spec. Any ideas?

Thanks!
 

·
Registered
Joined
·
5,847 Posts
Cleaned the MAF again.

Still no better.

Revs up to just over 2000 rpm on startup & then slowly drops to about 1100 rpm before slowly dropping to 800 rpm.

Seems a bit high when it only used to rev up to about 1300 rpm on startup before cleaning the MAF & TB.

Ford say all is good & everything is within spec. Any ideas?

Thanks!
Well I do not think everything is within spec. The car should not idle that low. What did you use to clean the MAF with? Have you used any octane booster?
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #53 ·
CRC MAF cleaner for the MAF & CRC Throttle Body cleaner for the TB.

Aren't the plugs supposed to be good for 100,000 miles?
 

·
Registered
Joined
·
9 Posts
Could be... Have you ever removed the throttle body before? If not, it's likely not the issue.
Speaking of Torque..here is somthing that is very strange. I have a 2005 mustang and I have never replaced anything under the hood except for the battery and Cam shaft postion sensors (2). I replaced the alternator and had to remove the throttle body. Absolutely none of the bolts were tight. I was preped to use alittle muscle and amazing I could just about untwist the screws with my bare hands. What is up with that?
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #55 ·
Revs still hanging between gearchanges :(
 
41 - 56 of 56 Posts
Status
Not open for further replies.
Top