Ford Mustang Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Wondering if you could possibly shed some lite on my missing horsepower. Long story short. Had shop A put in a 5.0 storker MMR shortblock to go with my whipple 2.3,steeda drive 18lbs boost, Longtubes,WWhipple Black diamond TB, Adam's rear intake,60lb inj, BAP,stage 2 comp cams, stock heads. While on the dyno snapped a cam follower, bent valves and basically had to have to the motor done over again at Shop A, They blamed everything on a clooged cat which did happen. Proably the result of his tune. Motor back together the car made 607 rwhp. Problems still existed at that point, fuel pressue erractic, general dirivablity sucked. I had enough and pulled the car (was there for a year). Had a guy install a BAP and took it to shop B. On his dyno( same type) only made 476 rwhp. Boost was 18.7 lbs at both places. Shop B was stumped. Thought maybe i am losing compression or or timing is off. He did mention that the ignition trace on the dyno run was very erractic. Not sure what would cause that..My buddy has a very similar setup and i have basically the his tune ..he made six and change. I really didnt push the car after getting it back from Shop A so i dont really know if i lost the horsepower..it seems pretty fast to me ....Any ideas ?...Thanks for the time...
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I think i can rule out the S/C made 18.5 lbs at both shops...plenty of fuel at shop B with 11.5 all they way across...he did notice some blue smoke at start up so maybe its pointing to rings..I have a compression check scheduled for the next week,,
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top