Ford Mustang Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter · #1 ·
i own a 2006 mustang gt, i have recently experienced a problem with my stang.... i've had my car for over a year now and recently (a month ago) i started the engine and less than a minute later it started choking and the rpm goes way below 1000 and the engines dies!!! i took it to the dealer and they said i had a problem with the fuel pump and they reseted the cams!!! got the car back and it was fine for a couple of weeks then, today, i had the exact same problem again!!!

could anyone relate to this problem or know anything about this? i want to know how to talk to the dealer so they don't confuse me with their weird talking!!!!

thanks mustang owners
 
G

·
DAYUM :headscratch:

That doesn't sound good at all.

I haven't heard of anyone having such a problem.

Good luck on the repair.
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #3 ·
thanks man, i'm taking it to the dealer tommorow to see what they say about it... i'll keep you up to date
 

·
Registered
Joined
·
516 Posts
as would i. or possibly a bad tps. pull a plug and see what it looks like
 

·
Premium Member
1965 Mustang coupe
Joined
·
72,863 Posts
as would i. or possibly a bad tps. pull a plug and see what it looks like
It's usually the TPS that goes bad vs the throttle actuator motor. But I think Ford usually replaces the entire setup. I replaced my TPS about 6 months ago.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top