Ford Mustang Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
So this sucks really bad! i have a 2006 mustang gt auto with 4.10 gears, stage 2 comp cams, 62MM TB, TCI shifter. bought headers off ebay (dumb idea) they dont fit directly and the driver side header is rubbing the steering shaft. so i got on americanmuscle.com and ordered new bbk long tube headers and a X pipe (without cats). the issue i am talking about now is it sounds like there is a knocking noise coming from the right side of the engine. to me it sounds like deep down in the engine! it is a loud knocking sound when i first start the engine when it idles really high where is the engine is still cold. after the car warms up there is still a knocking noise but it is kinda hard to hear it untill u pop the hood! then u can hear it when u put your ear down close to it but it seems like here lately it has been getting worse. so i stopped driving it. before i quit driving it, it seemed really slugish, when i would try to pull out it would almost act as if it had a miss, and even after it was warmed up when i would stop at a light it would idle low possable around 500 RPMS. what really confuses me is it does not have a CEL. i wwould figure that it would pop a knock sense code but nothing yet. my vehicle is really loud so it makes it hard to hear alot that does on with the engine (since i have no cats) but the knock is still loud enough that i can hear it. what could be the possable causes of this? cranck, head, piston, cam, what? my uncle owns a garage and he is a licensed machanic and he will be doing the work for me and i will be helping. but i would like to know what the possable causes is before i get started. any adivce will help thank you!
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
yes i have a SCT tuner and bama sent me 3 custome tunes before and after the work was done to it. ofcourse after i get my car done i am putting a supercharger on it and getting it dino tuned. any suggestions on what the problem might be. soon i am going to start ripping it down and i already have a new crank kit for it. i am thinking it might be a bearing on the crank due to the loss of power that i am experiencing. any suggestions would help.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #5
Toorbeenee, i would send post a vid but i have already ripped the car apart, as in ripp it apart i mean everything is already tore down even the pistons are out of it. i looked over the crank and it doesnt look like the bearings are messed up any. but i alreadyu have a new one so i am going to go ahead and do a rebuild on it. there is one thing that i noticed though when i was pulling out the pistons it almost sounds like something fell on to the ground. and when i was cleaning up the bottom of my heads it looks like on the driver side there was something laying on one of the the pistons and i can see where it had made contact with the bottom of the head and cut a few groves into it. i dont even know how something would have got down in there! but i still dont even know if that is where the knocking noise is coming from. right now i am porting and polishing the heads. might help a little with horses but what would u think is causing this knocking noise. oooo and i forgot to mention to mention both of my motor mounts were lose! not the part that connects to the engine but the part that bolts to the stud. any suggestions would be great
 

·
Registered
Joined
·
2,556 Posts
Were all the valves in good shape, no contact with the pistons? Is your TB still 100% in tact or is it missing any small parts? How did the rings look when you pulled the pistons? Something came off from somewhere unless something fell into the intake during the TB or CAI install.
 

·
Registered
Joined
·
559 Posts
Toorbeenee, i would send post a vid but i have already ripped the car apart, as in ripp it apart i mean everything is already tore down even the pistons are out of it. i looked over the crank and it doesnt look like the bearings are messed up any. but i alreadyu have a new one so i am going to go ahead and do a rebuild on it. there is one thing that i noticed though when i was pulling out the pistons it almost sounds like something fell on to the ground. and when i was cleaning up the bottom of my heads it looks like on the driver side there was something laying on one of the the pistons and i can see where it had made contact with the bottom of the head and cut a few groves into it. i dont even know how something would have got down in there! but i still dont even know if that is where the knocking noise is coming from. right now i am porting and polishing the heads. might help a little with horses but what would u think is causing this knocking noise. oooo and i forgot to mention to mention both of my motor mounts were lose! not the part that connects to the engine but the part that bolts to the stud. any suggestions would be great
sorry to hear that man,,,,post some pics :bigthumbsup.

i just took my engine out too, i just wanted to double check everything, been driving the car for a while with this turbo now so while i am at ill replace the rings and all new gaskets....all the best to u:bigthumbsup
 

·
Registered
Joined
·
74 Posts
Discussion Starter #9
to be honest after replacing the crank (had a new one so went ahead and replaced it)! bearings, gaskets seals, inspecting everything from top to bottom and everything looked good besides the marks on piston and the bottom of the head. its was the number 2 cylinder. but put it all back together and added a few more mods and the car doesnt knock or anything. idk what it was but i do know it was confusing to me and everyone at the garage i work at! my only down fall is my car is a auto and i installed a tci 3,000 torque converter and i am guessing i got ahold of a bad once since i checked the fluid and it was good, put fluid in the converter before i installed it and it is slipping like CRAZY! i mean its so bad that when i stop at a red light the car and i slowly get into it.. the rpms will have to be up to about 4,000 before it will engage and it jerks like crazy. lol and when i get on any slope and i stop when i try to give it gas the car will role up or down hill and i have to keep reving it up before it engages and goes. today when i tried it out again i went to a local store and when i tried to pull out the car wouldnt move for 30 seconds and i tried to make it do into gear. so i brought it straight home and parked it. tomorrow american muscle is going to hear some s**t from me!. Toorbeenee good luck to u man i hope everything works out for u! mine seemed fairly easy to do. :bigthumbsup
 
1 - 10 of 10 Posts
Top