Ford Mustang Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
i have 2006 gt with a steeda cai, sct tuner, and aftermarket exhaust. a few days ago i went to floor it and the car stopped pulling at about 3800-4000 rpms. it happens on and off but lately its been happening more often. the car sounds like when it hits 4000 it seems like its kind of in neutral revving. it has barely any pull and im really scared. the rpms start to creep slowly up to about 5000 and it seems to go no more. please someone help!
 

·
Registered
Joined
·
276 Posts
Could be your clutch slipping? May be new clutch time for you.
 

·
Registered
Joined
·
4 Posts
thats what it seams like to me. i have a friend that had a srt4 neon that had around 450whp and it took us a few trys to find a clutch that would hold it and his car was doing the same exact thing.
 
B
Joined
·
0 Posts
How many miles are on the car/clutch? If the rpms build slowly/sluggishly than I wouldn't start off pointing the finger at the clutch. If it was slipping the rpms would shoot up. The stock clutches can take a beating and the mods listed aren't enough to over power it. I would suspect tune if it is just intermittent. Try reloading the tune, double check all fitings, fluid levels and COP connections. Does it have problems building rpms or just feels sluggish? Dont forget about heat soak.
 
B
Joined
·
0 Posts
i have 2006 gt with a steeda cai, sct tuner, and aftermarket exhaust. a few days ago i went to floor it and the car stopped pulling at about 3800-4000 rpms. it happens on and off but lately its been happening more often. the car sounds like when it hits 4000 it seems like its kind of in neutral revving. it has barely any pull and im really scared. the rpms start to creep slowly up to about 5000 and it seems to go no more. please someone help!

...or maybe you confused me. Maybe a little better discription of what is going on and what/when your last mods were
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
How many miles are on the car/clutch? If the rpms build slowly/sluggishly than I wouldn't start off pointing the finger at the clutch. If it was slipping the rpms would shoot up. The stock clutches can take a beating and the mods listed aren't enough to over power it. I would suspect tune if it is just intermittent. Try reloading the tune, double check all fitings, fluid levels and COP connections. Does it have problems building rpms or just feels sluggish? Dont forget about heat soak.
only 11500 on clutch....car shoots up fast until about 4000 it just stops and makes alot of engine noise but no power. but it only happens sometimes..usually when i drive the car around for more then 20 mins it will start doing it...but at cold start opr just warming up it doesnt really happen
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
I'd almost bet my life that you have one or more failing coils.
how do you know? have you seen this problem before with failed coils?? it almost feels like my car just stops delivering fuel to it...i dont know what to do!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
other people have said it could be a fuel delivery problem...does anyone know if this sounds right???
 
B
Joined
·
0 Posts
if it doesn't happen all the time I doubt it is the clutch. I would look to do a little more of a process of elimination to better identify under what circumstances you notice these symptoms. No codes are being thrown? Do you have a scan tool? Double check all the fittings/connections. Something could be coming loose as under hood temps rise.
 

·
Registered
Joined
·
341 Posts
Originally Posted by stlwagon
I'd almost bet my life that you have one or more failing coils.
how do you know? have you seen this problem before with failed coils??

......he just has a knack for these things. You must not have been around this forum very long.;)
 
B
Joined
·
0 Posts
other people have said it could be a fuel delivery problem...does anyone know if this sounds right???
air, fuel and spark are the basics. Its a little difficult to diagnos without more information. Could be one of several things or a combination. Based on your mods you have listed you aren't exceeding the stock fuel systems.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
air, fuel and spark are the basics. Its a little difficult to diagnos without more information. Could be one of several things or a combination. Based on your mods you have listed you aren't exceeding the stock fuel systems.
i might know whats the problem but i havent ruled it out yet. the other day i tryed fooling with the tuner and i think i loaded the tune wrong so maybe i had no tune done this whole time...so just now i loaded the tune the correct way so im gonna try it out tommorrow . i am praying that it wont happen again!..ill keep you guys posted, thanks alot people!
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top