Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have some questions maybe you all can help me answer. When I orginally bought my car it was pretty powerful and had just had a brand new alternator put in that same day. It accelerated pretty fast and could easily hit 100mph without me having to floor it. On occasion though when I would park and get out I would smell like a burnt or burning smell. And now for the past week more often than not it is running really sluggish. I'll give it gas and the noise from the exhaust is tremendous however I barely accelerate. The tachometer immediately jumps up to the 4000 range but the mph barely hits 10 in 1st gear and it takes me awhile to build speed seeming to cap off around the 60 mph. I'm scared I've done something wrong and damaged my new baby. Any thoughts?! The mileage is around 112,5xx. Thanks in advance!
 

·
Registered
Joined
·
550 Posts
Automatic or manual transmission?
 

·
Registered
Joined
·
1,238 Posts
Sorry, I've only had a couple of minor problems with my Pony that I had the dealer take care of. That said, check around in Tempe for an independent that works on Fords. It's not like we're driving expensive European sports cars.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
That is true I was quoted 650 - 750 by AAMCO for parts and labor out the door. I just don't know if that's the lowest quote I can get. I'll check the forums and see what others have to say about having their clutch replaced.
 

·
Registered
Joined
·
1,238 Posts
Assuming they are quoting OEM parts and they know what they are doing, that is a very good price. Remember, you usually get what you pay for. Clutch replacement in just about any late model american car is usually $1,000+.

BTW, your middle name isn't batman? Sorry, I couldn't help myself.. ack.gif
 
1 - 7 of 7 Posts
Top