Ford Mustang Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
I am almost done with the V8 engine Swap on my 2007 mustang V6 it was more work than I thought but right now I have the engine and transmission installed, I also used the whole harness from the donor car, I changed the steering wheel column, the instrument cluster and the ECM. I have the key from the donor car but my problem is that it wont run. The security light on the instument cluster is flashing quick and when I try to start it nothing happens. I want to know if I have to reprogramm the key or what else can be wrong? I will really appreciate your help with this issue I want to drive my car!:D
 

·
Registered
Joined
·
13,170 Posts

·
Registered
Joined
·
1,018 Posts
It sounds as if it may be as simple as a ground issue. From what you have said, I would go back over every connections and the grounds twice. I have installed many motors over the years and when they won't start 99% of the time its a ground. Also clear all codes first. Another thing to look at would be the elec. connections at the tranny. Be it Auto. or Manual the connections need to be fully inserted and seated or it won't start either. There is a single studed block ground that attaches to the pass. side motor mount to frame rail, be sure thats tight too. The last thing I would do is pull the security system fuse (assuming donor car had one) see if there is an elec. connector located on the pass. side fender near headlight, if there is and your car orig. didn't have one then your going to have too cut connector and splice wires to each other. This will "fool" the system into thinking its working and the dash light should go out. Keep in mind this is only if the donor or your stock V6 had such a system. Let me know what happens.........:bigthumbsup
 

·
Registered
Joined
·
680 Posts
Wish i could help with that issue but i havent a clue. on a side note, you are my new hero. I hope to some day make that same swap, not that i dont love my six but by this point i want more power in the same car. care to share any details of your experience?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #6 ·
I had to reprogramm the keys and they fixed a wire that was damaged when the mechanic installed the engine. Now its working and wow the difference from the V6 is huge !!!:bigthumbsup Now I have a new problem the mustang has the check engine light on and sometimes it stalls. The mechanic scanned it and I believe its giving code 171 and 174 the car is running too lean on both fuel banks! Any advice on this problem?:D:D:D
 

·
Registered
Joined
·
9,239 Posts
The mechanic scanned it and I believe its giving code 171 and 174 the car is running too lean on both fuel banks! Any advice on this problem?:D:D:D
........Add fuel;)
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top