Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2007 Ford Mustang, V6, Shaker 500, 60k Miles


I'm out of ideas and any suggestions are appreciated.

Okay, so about 3 months ago I was driving down the road and the headlights started turning on and off. I pulled over, shut it off and tried to recrank, and all I got was the clicking of a dead battery. The next day I took it by Advance and it died again in the parking lot. Got it jumped off again and got them to check it and they said the battery and alternator checked out fine. I left there and stopped at the Ford place and left it for the day and they said they found nothing wrong, and charged me the $80 service fee and sent me along.

I discovered that when it started the clicking noise for the dead battery if I held it in the crank position it would slowly start to turn over and crank. However, when it did this the clock would reset and the 6 CD stereo would cycle. I went like this for a couple months, but in the past two weeks the holding it in the crank position doesn't work and it is simply dead. It dies about two times a week now.

Other problems I'm assuming are related are when I idle at a light or stop sign the RPM constantly drop to around 1k and the car shakes like it is going to stall then goes back up. Also, when I am driving down the road at night if I am not accelerating the headlights will dim, the interior lights will dim, and the air conditioner fan doesn't produce as much air. Also, when rolling windows up, they will get to about 2/3 of the way up and will decide to roll back down themselves.



Summary:

Cranking troubles: Couple times a week it would click like battery was dead. Held in crank position and it would slowly turn over and crank, but that stopped working about 2 weeks ago and doesn't start about twice a week.

Electrical Troubles: RPM drop when idling, feels like it is going to stall. When not accelerating or pushing gas pedal, lights will dim, interior lights dim, and a/c fan doesn't blow as hard. Windows often will start going up, stop, and roll back down.




I have had battery and alternator checked, cleaned the battery and terminals, and checked the connections. Any suggestions or ideas will be greatly appreciated.
 

·
Registered
Joined
·
6,430 Posts
These are all symptoms of a dead battery. If the battery is more than three years old replace it. Trickle charge the new one overnight before installing. Clean the connectors and check all grounds.

In my experience some of these batteries check out well on a load test but don't perform well in actual service.
 

·
Registered
Joined
·
11,864 Posts
These are all symptoms of a dead battery. If the battery is more than three years old replace it. Trickle charge the new one overnight before installing. Clean the connectors and check all grounds.

In my experience some of these batteries check out well on a load test but don't perform well in actual service.
welcome to the forums. i have to agree, those are the signs of a dead cell in the battery. ive had the headlight strobe light effect and those other issues in the 05 and the 06
 

·
Registered
Joined
·
1,448 Posts
I had similar problems maybe like half of a year ago? Sometimes it would start, sometimes it wouldn't. Sometimes it would die in the middle of driving. My clock would constantly reset. I couldn't use my power locks to get in my car sometimes, my rpms dropped out and killed it while I was still driving but my electrical would remain on. I've always had the power window thing happen on and off though.

Clean your battery terminals really well. That fixed all of my problems.
 

·
Registered
Joined
·
915 Posts
Sounds like the battery or the alternator. Same symptoms happened to me. Don't trust those parts places when it comes to checking those properly. Both of mine went within the same week and autozone told me they were both good when they did.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #7
Thanks for the help, it is appreciated. I replaced the battery and rechecked all connections and it seems to be running good now. Hopefully it holds up. (Had to put it in the body shop so we'll find out when I get it back out.) Thanks again for the help.
 
1 - 7 of 7 Posts
Top