Ford Mustang Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I recently had a shop install BMR lower control arms, adjustable third link, and panhard bar. Ever since then, whenever I begin to accelerate, I can hear one thumping sound coming from the suspension. You dont hear it anymore when you are driving, until you begin to slow down, then you hear another thump noise, and so forth. Is this normal because the bushings on the BMR are different than the factory ones originally installed? I just want to make sure my car isnt going to fall to pieces on the Interstate.
 

·
Registered
Joined
·
1,161 Posts
Something is not right. You shouldn't have any thumping noises coming from the rear. If you went with rod ends on your control arms, you will have some more road noise and vibration, but still no thumping noises. You need to get it checked out.
 

·
Registered
Joined
·
15 Posts
yeah, i would check the bolts on the upper control arm mount. i had a similar thump any time i accelerated hard and stooped fast, turned out that i didn't fully tighten one of the mount bolts.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
yeah, i would check the bolts on the upper control arm mount. i had a similar thump any time i accelerated hard and stooped fast, turned out that i didn't fully tighten one of the mount bolts.

Thanks, I'm going to check it out tomorrow morning.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top