Ford Mustang Forum banner
Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter · #1 ·
Mentioned in another post that I may have a fairly loose exhaust clamp. I;ve seen in the past some posts about heat shields. Anything I should be looking for?
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #3 ·
Kind of between the rear of the engine and the footwell. In the area of where the cat heat shields are. Doesn;t look like there is much you can do with the shields though?? I noticed how flimsy they are during the shifter install. I have some hearing issues so sometimes its difficult to source a sound, but can hear it. If that makes any sense:headscratch: The best I can tell that is where its coming from.
 

·
Premium Member
1965 Mustang coupe
Joined
·
72,878 Posts
Kind of between the rear of the engine and the footwell. In the area of where the cat heat shields are. Doesn;t look like there is much you can do with the shields though?? I noticed how flimsy they are during the shifter install. I have some hearing issues so sometimes its difficult to source a sound, but can hear it. If that makes any sense:headscratch: The best I can tell that is where its coming from.
It could be the dreaded center stack rattle
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #5 ·
You may be right. I think I have a loose exhaust coupler at the H-pipe / exhaust pipe jount. Saw some condensation dripping at the face of the clamp during shifter install. Forgot about it until today. Should be able to check the TSB when I check the clamp. If it is where I think it is.
 

·
Premium Member
1965 Mustang coupe
Joined
·
72,878 Posts
You may be right. I think I have a loose exhaust coupler at the H-pipe / exhaust pipe jount. Saw some condensation dripping at the face of the clamp during shifter install. Forgot about it until today. Should be able to check the TSB when I check the clamp. If it is where I think it is.
Let me know... I'd thought Ford had fixed this on the newer cars.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #8 ·
Let me know... I'd thought Ford had fixed this on the newer cars.

Looks like the exhaust hanger in the TSB is ok. Cross member piece aft of the transmission..They are their, nothing attached to them. The H-pipe looks to suspend from the cat pipe to the over axle pipes. I tightened up the H pipe clamps, three of the 4 nuts were not at spec but fairly close. I have noticed that it worse on different road surfaces than others. Not sure about the 05-07 cars, but the heat shields are very flimsy and right in the area that I am hearing and feeling this.
 

·
Registered
Joined
·
137 Posts
there is a TSB somewhere about the dust plate in between the engine and tranny vibrating........sounds like an exhaust rattle.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #12 ·
I'll check the bolts for the bell housing. Looked the car over under the hood today again. All seems well. I did notice the air box has some jiggle to it, but it felt more like the bushings it rides on nothing abnormal.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top