Ford Mustang Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
A couple of months ago, when parked at idle, I noticed an rpm surge. It stopped the next day. Last Monday it started doing it again, going from 7000 down to 4000 and back when parked. I also felt it while driving though the gauge didn't show it. I took it to the Dealer last Friday and they said there was a software upgrade and that should fix the problem. Today, the first day driving it since that day, it's worse. 5 miles from the house I felt it while driving, 10 miles from the house it, at times, didn't have power. I noticed the little wrench was red on the gauge. I parked, went into the store a few minutes, then restarted it. The wrench icon wasn't lit and it ran better but still had the slight surge. I stopped and parked, it had that same 4000 to 7000 surge at idle.
Had only normal maintanence this past year of ownership, with an air filter replacement in June.
 

·
Registered
Joined
·
2,083 Posts
Sounds like an issue with the drive-by-wire. Have the dealer take another look....shouldn't be too hard for them to diagnose it if you have CEL type of lights on.

Good luck! Let us know....
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Surge

Had a thought. What happens when you hit the reset button to reset the mph, except zeroing out the estimated mph?
I reset when I fill up and occationally while driving. I reset it during my last ride, then the surge got worse.
Coincidence?
 
F

·
Guest
Joined
·
0 Posts
A couple of months ago, when parked at idle, I noticed an rpm surge.
Hi bastropcc,

This is Deysha from Ford Customer Service. Please PM me with your dealer, mileage, VIN, and contact info so I can escalate it and help get this resolved.

Deysha
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Surge

Thanks for the offer.
The dealer just called and are ordering me a new Throttle Body and it should be ready tomorrow.
If that doesn't resolve it, I'll PM you immediately.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Surge 2010 Mustang GT

New throttle body installed and GT running fine.
Apparently there is a Tech bulletin out by Ford advising cleaning the TB. This isn't working and a replacement is needed to fully fix the problem.
My dealer said they have had a rash of these replacements recently and I'll bet it's due to the extreme heat and no rain in my area. 63 days over 100, no rain, dry and dusty.
As much problems as I have with my work and home computers, it's almost insane to have automobiles guided by the same technology. Thank goodness there's a "Safe Mode".
 

·
Registered
Joined
·
8 Posts
Did this surging ever hit as you are pulling away from a stop at a slow idle and the car literally surges as if you are stabbing the throttle? I have an 06 GT that is doing this. Very frustrating and have no idea where to look; maybe the throttle body. It does also surge at idle but it is not consistent about when it occurs (cold, warm, slow start, hard start, etc).

Also if it is the throttle body are there any gains to be had by going with an aftermarket throttle body? If you are going to have to replace something might as well upgrade if its worth it.
 
1 - 10 of 10 Posts
Top