Ford Mustang Forum banner

2011 mustang gt power loss/flashing check engine

7455 Views 6 Replies 5 Participants Last post by  akhant1
i have a 2011 gt/cs.steeda cold air,flowmasters,x-pipe with factory cats,mdx clutch,the revised pp bolts from ford,and brenspeed 93 tune. at 60-70 mph on the inerstate, if i downshift and hold the rpms at 4000-5000 for longer than a few seconds,the power cuts out and feels like an overdrive gear, while the cel flashes. it lasts for maby 10-15 seconds, then the power is restored and the cel goes off. i recreated the condition and hooked up my sct x3 when it started and got the p0300 multiple cylinder missfire code. it only happens in this one condition and only if im holding the rpms. if i downshift and go through the gears its fine. the changes that were made before this started were the clutch,pp bolts from ford, and went from a 91 custom tune to a brenspeed 93 email tune. any help would be much appreciated.
See less See more
1 - 7 of 7 Posts
i have a 2011 gt/cs.steeda cold air,flowmasters,x-pipe with factory cats,mdx clutch,the revised pp bolts from ford,and brenspeed 93 tune. at 60-70 mph on the inerstate, if i downshift and hold the rpms at 4000-5000 for longer than a few seconds,the power cuts out and feels like an overdrive gear, while the cel flashes. it lasts for maby 10-15 seconds, then the power is restored and the cel goes off. i recreated the condition and hooked up my sct x3 when it started and got the p0300 multiple cylinder missfire code. it only happens in this one condition and only if im holding the rpms. if i downshift and go through the gears its fine. the changes that were made before this started were the clutch,pp bolts from ford, and went from a 91 custom tune to a brenspeed 93 email tune. any help would be much appreciated.
Umm I was about to post something about this. But I have 2012 GT with just Roush CAI, AB and no tunes. I got CEL flashes around the same MPH last night coming back from work. I had cruise control on at 65MPH. Didn't notice much power loss. And it went away. But today, I was going to work and picking up Monster from the store and about to pull into parking lot and it flashes and my exhaust sound changes and felt loss of power but I was in the parking area already. I immediately ran the Vehicle Health Report and got Text from Sync saying "Immediately find a safe place to have your vehicle inspected before the concern becomes more critical"

I tried thinking about anything I have change recently and the only thing was I got gas from Wawa. About 5 gallons. I usually fill up at local Sam's club with regular.

A friend suggest that I should just use up all the gas and fill it up again and see anything comes up. I'll try to go back to stock CAI and troubleshoot it also.

Any thoughts or helps are appreciated.

I have about 1400K miles only.
See less See more
A flashing cel is usually a misfire indicator
Umm I was about to post something about this. But I have 2012 GT with just Roush CAI, AB and no tunes. I got CEL flashes around the same MPH last night coming back from work. I had cruise control on at 65MPH. Didn't notice much power loss. And it went away. But today, I was going to work and picking up Monster from the store and about to pull into parking lot and it flashes and my exhaust sound changes and felt loss of power but I was in the parking area already. I immediately ran the Vehicle Health Report and got Text from Sync saying "Immediately find a safe place to have your vehicle inspected before the concern becomes more critical"

I tried thinking about anything I have change recently and the only thing was I got gas from Wawa. About 5 gallons. I usually fill up at local Sam's club with regular.

A friend suggest that I should just use up all the gas and fill it up again and see anything comes up. I'll try to go back to stock CAI and troubleshoot it also.

Any thoughts or helps are appreciated.

I have about 1400K miles only.
well maby i can rule out the tune since yours did it with the stock tune.
See less See more
A flashing cel is usually a misfire indicator
Yes, it is. This is usually how the #8 cylinder issue starts. You should have your car towed to Ford, but your warranty claim will probably be denied.
Have Ford run the crankshaft misfire correction procedure. This is known issue.
The stock CAI has been reinstalled. I test drove the car and still didn't get any errors yet. I made appointment with the dealer just to be on the safe side.
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top