Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1 (Edited)
About 3 years ago I went to get my car inspected before being put in storage for winter. To my surprise it failed due to the 02 htr and o2 monitor being not ready. The car runs fine. Over the next couple of years I drive the car sparingly and took the tune off and on trying to get it to set. Followed to drive cycle sequences more than I can count. I'm now at the end of another year with the monitors not being in a ready state.

I did take the car to my dealer last year and they stated the "aftermarket" tune was causing the problem. I don't believe this to be true since I ran the car an entire season on the stock tune trying to get the monitors to turn on and FRPP tunes don't turn off any emissions equipment.

At this point I'm thinking the dealer will have to reprogram the computer with fresh OEM software or it needs a new computer. Does anybody have an insight of the problem or suggestion for repair. This has been pissing me off for 3 years! The car has only ~12k miles on it.
 

·
Registered
Joined
·
4,874 Posts
1st, put it back to stock tune, then do the drive cycle and evaluate
 

·
Registered
Joined
·
178 Posts
Discussion Starter #3
1st, put it back to stock tune, then do the drive cycle and evaluate
Yup did that about 3 times and drove anywhere from 200 to 600 miles like that with tons of drive cycles included. Not the problem. Checked for exhaust leaks. It's fine.

Also never any codes.
 

·
Registered
Joined
·
178 Posts
Discussion Starter #5
Time to check to see if there is voltage to the sensors and the connectors have a signal
They have voltage and are reporting correctly on my scanner. One is a little slow but not much.
 

·
Registered
Joined
·
9,814 Posts
these issues are usually tune related, with the sensors turned off in the tune . . . seems like that is not the case if you have loaded the OEM tune but that is the first thing I would verify . . . but I am not clear; are you running the FRPP tune or the original factory tune? I would not be surprised if the FRPP tune does actually turn off the downstream O2 sensors; since they are only used to confirm that the cats are working and have near-zero affect on how the car runs

after that it's the mysterious drive cycle . . . seems like you have that covered too

I doubt it is the computer itself but I guess that is possible
 

·
Registered
Joined
·
178 Posts
Discussion Starter #7
I've tried the FRPP tune and stock tune for hundreds of miles to no effect. I did read in a post that the FRPP tune will shut off the down stream o2 sensors if you have a manual transmission. I have an auto.

Just had a conversation with Ford Racing and they insisted it was not their tune that is disrupting the o2 sensors from being ready. So the dealer is blaming the tune and FRP is blaming the dealer for not knowing what they are doing. Meanwhile I've been stuck with a 3600# paper weight for nearly 3 years.
 
1 - 7 of 7 Posts
Top