Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
i bought this low mileage stang from a family member that it took 25 years to get the car from him.she has been sitting in the garage since 1971.i replaced every rubber part i could find.i bought the drake shifter bushing kit to take the sloop out of the shifter,but now it has a chater sound unless i rest my hand on the shifter. is this normal to hear for a car that has 43000 miles on her?the car has the 289 with a 3 speed manual trany.the only other options was the wire hubcaps and the am 8 track player.
i am worryed that i am going to mess up the trans by resting my hand to stop the chatter vibration noise?
plus the shifter still has lots of sloop in her.but i cant find a new old stock shifter anywere.
 

·
Registered
Joined
·
39 Posts
shifter..

what kind of trans is it? you got a speed shop around town? take it there or call and see if they can point you in the right direction..sorry not much help but it an idea.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
sorry it took me so long to reply back[health problems].the trans is whatever ford user in the building of her.it is bare bone stock,and i want to keep it all stock.the only thing i could think of is to replace the shifter with an oem on,but there hard to find,i havent found one yet.you would think with all the resto/rods out there,most guys replace these with the 4 speed ,for better performance.not me,this car will remain all stock as she came from the factory.

anybody got a 3 speed shifter laying in the old parts box ????
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
i also have another problem if i go from a dead stop,and a bit of gas ,releasing the clutch the car shakes violently but if i am easy on the gas its OK.could this be a worn out trans mount?has anybody ever had this problem????
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
the feel is like a real bad wheel hop,but its there all the time,what can i do to corect this problem????
 

·
Registered
Joined
·
101 Posts
You said you repaced all the rubber you could find. Di you also replace the motor mounts? This can sometimes cause the jerking you aree feeling.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
i did replace the motor mounts but not the trans mount,would this cause the shuddering on take off?
its real bad the entire car is shaking.
 
1 - 7 of 7 Posts
Top