Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter #1
Ive got a 306 with a vortech v1 42lb injectors, 155 pump, 4:1 fmu, holley 35-65 adj. regualtor, msd btm . Car was dyno tuned 2 years ago, has been running great. was getting 15mpg city and around 20 hwy. Just fixed ac 3 weekends ago, had to idle car up a little bit to run ac compressor, readjusted tps to spec, It ran fine for 2 weeks. Now its running pig rich , dumping raw fuel out left tail pipe, Air/ feul meter staying pegged out on rich on driver 02. I hooked up my snap on solus and did a key on engine off and key on engine running and had a code 42 : right o2 detects rich.. Car is still running fine just burning a lot of fuel. Has anyone had problems with ford racing 42lb injectors leaking? The injectors were bought brand new and now have 16k miles on them. Im thinking bad injector or bad / lazy o2. I have not pulled the plugs on this bank yet.
 

·
Registered
Joined
·
13,166 Posts
PLug gaps on these apps from my experience tend to close down when they get worn. Probably just need a tune up. Check your fuel pressure and check the reg vacuum line for gas. Also maybe the extra load from the AC has effected the tune or is causing the plugs to be too hot. Pull the plugs and check em for cracks and color.
 

·
Registered
Joined
·
174 Posts
Discussion Starter #3
I will check it.. the plugs have about 16k miles on them since Ive checked them. Fuel pressure is good i checked it first.. Its right where i left it last time I adjusted it. That works man A set of plugs is cheap .. You been doing alright spdjnky?
 
1 - 3 of 3 Posts
Top