Ford Mustang Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hello, to begin with i just got my mustang back recently from a mechanic, swapped the block because mine was cracked due to an idiot who didnt put antifreeze back after flushing radiator, anyway i get the car back and its running very rich, so rich it burns your eyes cant stand to drive the car, dont know why replaced the o2 sensors not as rich but still some, also it idles up and down for a minute or 2 when you start it, longer than before i had the work done, has a new e-303 cam, it will run if you leave it idling for a few minutes then dies after up and down surging, when driving the car it has the occasional cut out, and when you slow to stop or turn it will die but not everytime, can anyone give me any ideas or tell me directly what is wrong with it, any advice is useful, i have no idea, thank you.
 

·
Registered
Joined
·
46,010 Posts
Need more info. Is it stock other than the E303? Anything else done to it? What condition is the fuel system in?
 

·
Registered
Joined
·
540 Posts
i'd say check your ECM Grounds since the engine was replaced, and since someone else did it, and i also agree with Eagle, little more info, when was the fuel system last serviced
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
i'd say check your ECM Grounds since the engine was replaced, and since someone else did it, and i also agree with Eagle, little more info, when was the fuel system last serviced
not sure when the fuel system was last serviced, but what exactly is ECM???
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top