Ford Mustang Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
my car all of a sudden has a low surging idle and then shuts off? only idled funny in cold start, does have a cam but dont kno what kind. could that be the reason? if so why is it happening now and not before?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
sounds good, ima check it out tomorrow. what is a PIP?
 

·
Registered
Joined
·
269 Posts
Also check your igntion module, on the dizzy. pretty common failure on our cars
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
the vacuum Ts on the fire wall one of them were cracked. but now the oil pressure gauge stopped working? all wires are connected and the car is full of oil?
 

·
Registered
Joined
·
269 Posts
the vacuum Ts on the fire wall one of them were cracked. but now the oil pressure gauge stopped working? all wires are connected and the car is full of oil?
Replace your oil pressure sending unit!
 

·
Registered
Joined
·
703 Posts
Could be alot of different things. Before you start buying a lot of different parts and guessing at the problem. Take spdjnk's advise and run the codes so you can pin point the issue. Good luck!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #9
Well found out why the sudden loss of oil pressure. Oil pump seized and broke the shaft. So at the moment the k-frame is dropped and pan is out. Waiting for the new pump to come in and continue this nightmare.
 

·
Registered
Joined
·
75 Posts
Gotta love it welcome to my world my wife took my cards check book after i went to the part store for the tenth time this week im gonna find em soon thow daddy needs some new MT drag radials:yup:
 

·
Registered
Joined
·
19 Posts
Discussion Starter #11
ya so i got the new pump in and everything bolted back together but since it still has the stock suspention the old spring one of the coils broke off in the control arm so i called it quits for the night and gonna figure it out tomorrow morning
 
1 - 11 of 11 Posts
Top