Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi, i can not seem to find the right fuse diagram for what i have. i tried rearranging some fuses to a diagram i found online but now my dome light doesn't work, i cant lock my doors from the inside. And when i push the unlock button all my parking lights come on, i'm like how the hell did i do that!! And it's a 96 mustang v6, can someone please find the right one. Its the two rows of mini fuses i need.
 

Attachments

·
Registered
Joined
·
12 Posts
Discussion Starter #2
okay so i found the right fuse box, it was in the 1999 owners manual, so i put all the fuses back in the right spot but nothing still works right as i described previously.
 

·
Registered
Joined
·
6,859 Posts
1996-1998 BJB & I/P Fuse panel layout

Something is very strange. Why does a 96 MY car have a battery junction box from a 99+? What about the I/P fuse panel? Is it 96 or 99?

FWIIW, for the 96 MY, the remote key less entry is powered from I/P circuit breaker 12 and I/P fuse 8. Sure sounds like there is no power to the GEM.

Why are you rearranging fuses? Seems like a strange pass time.
 

Attachments

·
Registered
Joined
·
12 Posts
Discussion Starter #4
ok, found out when i went to the mechanic today that my car is a 98. And the fuse box under the dash is the original one, i got an electrical problem, anybody know what would cause the speedometer to not work, i would rather try to fix this myself than spend another $200 for nothing again.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
so i found out my car is a 98 not 96 when i went to the mechanic. I have some kind of electrical problem, i wanna start with my speedometer not working, anybody know what it is? All fuses work, and had my gauge cluster changed
 

·
Registered
Joined
·
6,859 Posts
Check the ground behind the center console. It's frequently mess-up during a radio install.

The other problems mentioned have the GEM in common.

Guess what? The GEM is also grounded at the same spot.

Your welcome.
 

·
Registered
Joined
·
1 Posts
so i found out my car is a 98 not 96 when i went to the mechanic. I have some kind of electrical problem, i wanna start with my speedometer not working, anybody know what it is? All fuses work, and had my gauge cluster changed
have the instrument cluster rebuilt it will fix the problem see if that will help you
 
1 - 7 of 7 Posts
Top