Ford Mustang Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 · (Edited)
Hello! I have a 97 mustang gt that has been running flawlessly. A few weeks ago a tree fell on it and broke the windshield, cracked the hood and dented both front fenders. Seems like ever since then the car has been doing weird things.
1- Go to start it and it seems like the battery is dead. Jumped it and it started right up. It does this every now and then but It doesn't need to be jumped sometimes. ( new battery and alternator and new fuel filter installed last year)
2- go to start the car and it will turn over for 1-2 seconds and die. Recycle key will do the same thing. Recycle the key and it will start and stay running. Seems like I have 2 separate problems now. I put 2 and 2 together and figured hey maybe the impact of the tree hitting the fender messed with the ccrm box?. Are my problems I’m having familiar with a bad ccrm box? Or any ccrm problems? Dirty IAC valve? It’s just weird because it doesn’t happen at every start. Maybe after sitting the night it may happen. Another time I drove the car for about 30 min parked it went into a store.. came out and no start just a click. Cycle the key would click again, cycle the key it would start and run flawlessly. I seem to have good fuel pressure but can’t really tell my pressure guage leaks gas when It’s priming at the fitting. But it squirts out so the pressure seems to be good… Any other things to check or any advice? I have no check engine light on either. No codes from the scanner either. Could it be a Bad ccrm box? Thank you
 
1 - 3 of 3 Posts
Top