Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
ok i have a 98 4.6 gt auto (just bought it) and i dont have catalytic converter's just stock headers h pipe with cherry bombers my car didnt run good when i floor it felt like something was holding it back i changed the oil nothing so i put new spark plugs nothing then a new fuel pump/fuel filter but nothing then i got the 2 front o2 sensors nothing so i just got the rear o2 sensors new spark plug wires 2 new coils for 100% off from my bro's work and now it hauls ass but now i have a P0420 code which is the catalyst efficency below bank 1 but i dont have cat's and theirs alot of reading but no one seems to have cleared it the car runs better then before so i dont think their the o2 sensors it use to go vruumrrrrrrrrrrrrrrrmmrrrrruuummmrrrrruuuuummm
and now it goes vvvvvvrrrrrrruuuuuummmmmmmmmmmmmmm like it's soppose to pls help
 

·
Registered
Joined
·
6,856 Posts
Just wondering why you are replacing the rear O2 sensors when the car does not have cats. The only job that the rear O2's perform is monitoring the cats.

When the cats are removed a MIL is needed to keep the check engine light from coming on.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #3
i didnt know that now i do, i just thought that the rear o2 sensors werent connected and thiught that was the problem does it really work with the mil eliminator my car runs fine but it's juct the check engine light that sux to see it every time
 
1 - 3 of 3 Posts
Top