Ford Mustang Forum banner

Status
Not open for further replies.
1 - 20 of 29 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Recently purchased a 98 Vert v6 for my g/f. This was a fixer upper so it was a bit cheap. The car originally didnt crank took it to my mechanic turned out it was the fuel pump that was bad. Replaced it and 48hrs later Car wont start AGAIN! I think it has something to do with the Wiring in it.

1.When i honk the horn it stays stuck and keeps honking until i unhook the battery.

2.The trunk release in the glove box doesnt work. BUT sometimes when i hit the car unlock button for the driver door (if the ignition is open) IT UNLOCKS THE TRUNK.

3. The lights on the Sun Visors dont work.

4. There are some plugs by the cold air intake that arent plug BUt i have NO IDEA where the hek they go to??

I looked up the fuse box diagram and it doesnt even look like the fuse box thats in the car. Im thinking they swapped it with one that doesnt belong to this car. I have attached some pictures of the fuse box and the connectors that i have no idea where they go??

Both connectors are located on the RH Passenger Fender.
Any info would help with this PHSYCO CAR!.

Thanks!
Alex
 

Attachments

·
Registered
Joined
·
11,432 Posts
ALEXX_302 said:
Recently purchased a 98 Vert v6 for my g/f. This was a fixer upper so it was a bit cheap. The car originally didnt crank took it to my mechanic turned out it was the fuel pump that was bad. Replaced it and 48hrs later Car wont start AGAIN! I think it has something to do with the Wiring in it.

1.When i honk the horn it stays stuck and keeps honking until i unhook the battery.

2.The trunk release in the glove box doesnt work. BUT sometimes when i hit the car unlock button for the driver door (if the ignition is open) IT UNLOCKS THE TRUNK.

3. The lights on the Sun Visors dont work.

4. There are some plugs by the cold air intake that arent plug BUt i have NO IDEA where the hek they go to??

I looked up the fuse box diagram and it doesnt even look like the fuse box thats in the car. Im thinking they swapped it with one that doesnt belong to this car. I have attached some pictures of the fuse box and the connectors that i have no idea where they go??

Both connectors are located on the RH Passenger Fender.
Any info would help with this PHSYCO CAR!.

Thanks!
Alex

That's the wrong fusebox. That's the engine management stuff, the fusebox in your diagram is in the passenger compartment.

Ok, those are engine management sensors, Best guess is the TPS which should be near the intake, and the EGR sensor. How long have they been unhooked?
 

·
Registered
Joined
·
11,432 Posts
Do you have a Chiltons?

you're proabably going to need to clean the connections before you try hooking 'em up .. .
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
The plugs probably have been un-hooked for a while. The car was sitting for over 6months. But also ive noticed that the harness that plugs into the fuel rails has been tampered with of some sort. So I might just replace all the wiring harness's in the engine compartment to make sure. What years am i compatible with? 94 - 98 am i compatible with any GT's? thanks for the info.
 

·
Registered
Joined
·
11,432 Posts
It's not on th ebackside of the lid?

It looks like the fusebox in my Chiltons ..

except the little ones in the foreground. Those are different.

Ok, 1996-1998 have a differnt box.
 

·
Registered
Joined
·
11,432 Posts
Do you have a Chilton's or Haynes?
 

·
Registered
Joined
·
11,432 Posts
Starting at the top

Relays

1) not used

2) Horn

3) Starter

4) Fog Lamps
 

·
Registered
Joined
·
11,432 Posts
2nd row Maxi Fuses

1) Amber Ignition Switch 40A
2) Amber Ignition Switch 40A
3) Amber Ignition Switch 40A
4) Red Headlamps 50A
5) Yellow EEC 20A
6) lt. Blue Engine cooling fan 60A
7) Lt. green Thermactor Air Pump (4.6L only) 30A
 

·
Registered
Joined
·
11,432 Posts
3rd Row ATC Fuses

1 25A natural Power Seats
2) 20A Yellow Horn, foglamps, DRLs, Control Module
3) 25A Interior lamps
4) 25A Natural Audio
5) 20A Yellow Alternator
6) 30A lt. Green Cigal Lighter
7) 30A Circuit Breaker for Convertible Top Motor
8 60A Lt. Blue, ABS
 

·
Registered
Joined
·
11,432 Posts
There was a 1998.5 that had some wiring in common with the 1999s.

But the fuses should be described on the back cover of the fuse box.
 

·
Registered
Joined
·
11,432 Posts
The connector on the left, from Chilton's, is probably either an oxygen sensor, an AC cyclic pressure switch, or an EGR sensor

On the Right, it looks like an Idle Air Control solenoid, an EGR vacuum regulator, a secondary air injection diverter, or a SAI bypass.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #13 ·
I have the Chilton book#26608. Im thinking i should just try and get a fuse box from a 96-98 for this model. That way theres no diffrence in the fuse box? Or if anyone can confirm that the box shown on the pics is the exact same thing as the one for a 98 model.

thanks
 

·
Registered
Joined
·
11,432 Posts
ALEXX_302 said:
I have the Chilton book#26608. Im thinking i should just try and get a fuse box from a 96-98 for this model. That way theres no diffrence in the fuse box? Or if anyone can confirm that the box shown on the pics is the exact same thing as the one for a 98 model.

thanks
It's in Chapter 6.
 

·
Registered
Joined
·
11,432 Posts
There are 3 fuseboxes

1994-1996

1997-1998

1998.5
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #16 ·
Not sure if you have a newer version or something but on 6-46 Chassis Electrical - I show 2 pictures of a 94 box and on the bottom half of the page theres a 95 model. Then on page 6-47. I show a 96-98 model. The diffrences im talking about if you look at the picture i attached at the beginning of this post, Youll notice that the box on the car now is capable of holding:

5 Relays - Instead of 4.
12 Maxi Fuses - Instead of 9.
& on the last row (ATC Fuses)
All diagrams show it can hold 8 fuses total. Yet the box on the car can hold 12 tiny fuses + 4 additional. Im just trying to find out if maybe this doesnt even belong in the car. UNLESS someone else outthere can confirm that the box i show on the picture looks EXACTLY like the one on theyre car. I would really appreciate it because its driving me insane! :) Thanks for all your help! kscoyote.

Rgds,
Alex
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #17 ·
forgot to include that - CAR DIDNT COME WITH THE FUSE BOX LID so cant get any info from that?
 

·
Registered
Joined
·
11,432 Posts
you must have a 1998.5 model.

You're probably going to have to look at a 1999 model.
 

·
Registered
Joined
·
11,432 Posts
kscoyote said:
you must have a 1998.5 model.

You're probably going to have to look at a 1999 model.
Or go to a dealership. They could make a copy for you . ..
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #20 ·
Ok guys i switched the whole wiring harness. Now everything works just fine lights signal. Trunk release the whole shabang! BUT!!!!! car still wont start. NOW as soon as i plug the battery up the THEFT light starts blinking like crazy also the abs light is on at the same time. Only both those lights come on! and i get no start or nothing actually when i put the key in there and turn it. anyone know any solution to this??
 
1 - 20 of 29 Posts
Status
Not open for further replies.
Top