Ford Mustang Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter #1
Hello,
Live in south west Texas, DESERT, it was 100 F today :happyhapp

Recently lost cold air on my A/C; so I went out bought a charging kit. The gauge reads that it is empty. Punctured can let it open but the system is not charging and the contents of the can aren't emptying at all. Car is on Max A/C HI fan etc etc all instructions followed.

Is the compressor not turing on? I know when the compressor kicks in the gauge looks like its throbbing a little, it didn't do this.

Any ideas? :headscratch:

Appreciate it!
 

·
Registered
Joined
·
5,329 Posts
Sounds like the compressor isn't turning on, you can tell by looking at the pulley, there are 3 knob looking things, when the clutch locks up to turn on the compressor they start rotating, if they are standing still its not turning on. Also make sure the valve on the can is open, when you puncture it, you then have to open it or the needle will block the hole and only let a trickle through. There are other reasons why it might not kick on, like a bad clutch or pressure switch, but my guess is you may have forgotten to open the valve after puncturing the can. No insult intended, just something I've seen people do before.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #3
Haha no insult taken :gringreen but I'm sure it's punctured and released. I even disconnected the hose released the needle slowly and it came out. So the can and hose are good. I my best guess is te compressor. Just wanted to check if anyone knew or could relate to the situation.

If compressor is not turning on does it need to be replaced?
 

·
Registered
Joined
·
613 Posts
Hello,
Live in south west Texas, DESERT, it was 100 F today :happyhapp

Recently lost cold air on my A/C; so I went out bought a charging kit. The gauge reads that it is empty. Punctured can let it open but the system is not charging and the contents of the can aren't emptying at all. Car is on Max A/C HI fan etc etc all instructions followed.

Is the compressor not turing on? I know when the compressor kicks in the gauge looks like its throbbing a little, it didn't do this.

Any ideas? :headscratch:

Appreciate it!
Those cans are garbage. If you have no freon in the AC system it's because it leaked out. Even if you got the can to work, it would just leak out again. Take it to the dealer. They will charge it, then add dye to the system to check for a leak.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top