Ford Mustang Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
1984 mustang V8 302 5.0L
i just rebuild my engine, .30 piston flat head, performance camshaft, shave heads, port all than its portable =:__], car has an edelbrock perforer manifull, 600cfm 4 barrel carb edelbrock also , mallory electronic distributor, accel 55,000 V super coil, 8.8 accel spiral wires, plit fire spark plugs, air filter, gas n' oil are K&N, remplace all hoses with MAC chrome tubes, and of course headers... So the engine now has 1500miles, im starting to push the engine harder and i found a horrible issue, from 500rpm to 2900rpm, the car is just perfect, but if i try to pass 3000rpm the engine stall "dies" on the try, i haveto pull my foot out of the gas cause it useless, to try to explain msyelf better heres an example, from 500rpm to 2900rpm 2 seconds, and from 2900rpm to 3100rpm 6 seconds. hope tht help.
heres pic off stuff inside the eng.
 

Attachments

·
Registered
Joined
·
73 Posts
I kind of had the same problem on my 85. Car pulled good from idle to 3000 and then above that it would break up. I found that the connector to the Duraspark box had insulation missing from it and some of the wires were touching. I moved them apart and the car seems to be better. I havent really gotten a chance to take it out and drive it more than around the block.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
ty man, i will try tht =:_]
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top