Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
How does this add horsepower? Can anyone fill me in?
 

·
Registered
Joined
·
767 Posts
Don't believe the hype. Jim Sr. from JDM and Doug from BamaChips have both dyno'd them on NA and SC cars and shown absolutely no gains, and posted the dyno sheets to prove it. There are multiple threads on The Mustang Source, Modular Fords, and Mustang Forums of people complaining about the lack of performance gain compaired to the advertised gains. Then they try to convence you that they are OK with only getting 1hp for their hard earned $500 by explaining how cool the new TB looks.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
Thanks for the insight hawg. I'm glad I asked about this.
 

·
Registered
Joined
·
26 Posts
I had some Gains and improved Throttle response
There are some issues with these that people are not pointing out.

First off. I have an 2005 Mustang GT Automatic Trans Bone Stock Dyno results - 252hp 261Tq -
K&N Aircharger installed with SCT XCAL II Tune from V-8 Power.
263 hp 271Tq
http://home.comcast.net/~swieduwilt01/Cars/dynorunc.jpg
My Dyno Sheet with K&N Aircharger and GMS 62mm Throttle Body
271 hp 280Tq thats a 8hp and 9 tq gain
The K&N MAF size is the same as stock so I did not expect any huge gains with this CAI. I am switching to a JLT II next week.

Also a link of a unbias test at Grannatelli Motorsports
http://forums.bradbarnett.net/index.php?showtopic=43704

Now the Down sides no one is reporting.

Since the installation of the Grannatelli Motor Sports Throttle Body I have been annoid by a constant Idle surge when sitting in drive waiting for lights, it bounces between 700 and 900 rpm. Then a week after the installation of the TB and Dyno Tune I started getting a Clicking noise in the mornings before I start the car (turn the key to accessory position). after the clicking stopped the car would start normally. I contacted GMS and they stated that they had a couple of customers have this issue. It is cause by the throttle actuator trying to get a throttle position. Ok, well No fix for this, Then a month lator the car gave me a couple of error codes and would start but the throttle when pressed would not accelerate. the P codes stated that the Throttle was stuck closed. So I reset the PCM and was able to get it running for a few hours then got a code stating the throttle was stuck open. At this point I replaced the Stock TB and was fine after that. Again No fix as of yet, I think the Throttle adjustmet screw is slowly walking in or out. There one other problem is a high idle when you take your foot off the gas, just for a couple of seconds.

Over all I an neutral on this MOD If it worked right and was a little cheaper I t may be worth it.
 
1 - 4 of 4 Posts
Top