Ford Mustang Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter · #1 ·
Hey all...Well just to give an update my alternator issue was just that...bad alternator...I changed the regulator first and it got fried immeadiately and there was no charging at all so I just swapped the whole damn thing...Presto...perfect 14.2 charging going on now...As for the check engine light thing I was able to do a little more testing today on the car by driving it...The check engine light is only coming on at times when I am coasting and I can instantly make it go away by putting my foot on the gas just a little bit or a lot doesn't matter...This makes me think Paxton's educated guess of a fuel build up b/c of the s/c is at least in the ball park...Still haven't pulled the code yet but at least I know how to stop it...Here is a pic of my finished install:

http://www.ptg4air.com/pics/finpax.jpg

The car sounds amazing, I took a short 10 second video of it today reving with sound and i'll try to post it this weekend...Anybody have any more guesses as to whats going on with the check engine light now that I know by giving a little pedal it goes away...I know I need to pull the codes just wonder if this has ever happened to anyone...I also know it has everything to do with the supercharger just not exactly what....

Jason
 

·
Registered
Joined
·
4,809 Posts
I'd pull the codes and avoid guessing. Do you have a wideband setup with your s/c?
 

·
Registered
Joined
·
115 Posts
Discussion Starter · #3 ·
Ghost thanks for the post...Yeah I know I need to pull the codes I will when I get a scanner...Or maybe find someone who does and get it done...What do you mean by wideband setup???...I am new to s/c'ing
 

·
Registered
Joined
·
3,404 Posts
I don't know much about S/C'ing, but I do know that a real bad vacuum leak will cause the light to come on during decelleration, so be careful because it might be leaning out on you. Isn't there something like a blow off valve for a S/C? I'd check the operation of that. The car needs that valve or whatever for when the throttle is closed.
 

·
Registered
Joined
·
115 Posts
Discussion Starter · #5 ·
Mean green...There is no blow off valve in this kit but there is an open threaded hole about an inch in diameter with a stainless plug in the ubend intake...I have the plug installed to Provide full boost...Maybe it should not be there...You bring up a good point...does anyone know????...I'll call paxton next week and ask if I don't get a response...there was nothing in the instructions about it...I just figured it would need to be plugged...it seemed logical...I'll email Clint Walker and ask him...Thanks for the response
 

·
Registered
Joined
·
897 Posts
cfiiman said:
Ghost thanks for the post...Yeah I know I need to pull the codes I will when I get a scanner...Or maybe find someone who does and get it done...What do you mean by wideband setup???...I am new to s/c'ing
Hi,

Great install......you don't have to wait for a codes scanner, check the procedure TDY at http://fordfuelinjection.com/?p=13, it will help in getting the information to id what the system might be registering. GL
 

·
Registered
Joined
·
115 Posts
Discussion Starter · #7 ·
Thanks Joel...Great post...That is exactly what mine looks like...I'll be doing it this weekend....Thanks guys!
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top