Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Ok... my alternator went out on me about 5days ago. I took it to a guy that is well respected in my area for rebuilding alts. Well he said it would take him 2-3days and he called in one saying he was done. I was thrilled to say the least, so I ran and got the rebuilt alt. and put it back on my GT. I replaced the battery because of the bad alt. eating up the old one and everything worked until this morning... My GT starting loosing power driving down the road AGAIN, so I pulled over and as soo as I got out of traffic's way it died. It won't turn over and clicks when you try to start it. So I'm thinking my alt. is completely bad and I need a new one? :headscratch:
 

·
Registered
Joined
·
625 Posts
yea...if you got a new battery then your car was just running off it until it couldn't put out enough juice anymore. take your alt to autozone and let them hook it up to there machine...don't cost anything and that way you can be positive when you call the guy back that worked on it and tell him it is still not working.
 

·
Registered
Joined
·
210 Posts
I just went through the same problem with my 96 gt I had replaced 2 alt in 6 months and killed 2 bat It ended up being the positive battery cable harness it was shorting out the alt you might want to look into that before you start wasting money like I did had to get the harness from ford good luck
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
Well guys... after a few hours I figured out what was wrong with my GT. I took my alt. off and got it checked to make sure that wasn't my problem, it checked out good so that was a relief. Me and my grandfather, whom is the most respected diesel machanic around, spent an hour checking EVERY plug in and EVERY wire possible. Turns out that my power cables that runs from my battery to my fuse box had burnt in half, which was disabling my alt. from charging. So I cut the burnt ends off and sadered them back together. Now she runs and looks 100x better than before :D. Anyways thanks for everyones help! :bigthumbsup
 

·
Registered
Joined
·
603 Posts
autozone has them for 140 and has a warranty
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top