Ford Mustang Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter #1
I tested my alternator at advance auto parts and they said it was good. The guy later told me that it could be the voltage regulator. I later got a voltage regulator and replaced it. After i replaced it i got in the car drove it about half a mile down the road. I turn around go back to my house and cut the car off. I took the key out and tryed to crank it again. It hardly turned over. What could the problem be?
 

·
Registered
Joined
·
46,010 Posts
How was the car acting after you replaced the regulator?
 

·
Registered
Joined
·
152 Posts
Discussion Starter #3
I could not tell any difference between the two. I could not put the old one back in even if i wanted to because its coming apart. So the old one was for sure shot.
 

·
Registered
Joined
·
152 Posts
Discussion Starter #4
hooked up battery charger for about an hour. It charged it a good bit and so i get into the car start it up and take it for a test drive. It was doing fine till i turned on the radio and my electric fan might have turned on. I guess its the alternator but the guy tested it and said it was fine. Is it possibley the battery?
 

·
Registered
Joined
·
46,010 Posts
Could be the battery, but it sounds more like the charging system. If you could get it to the tester and have it done while it's running, they can make changes to the test and tell what side of the system is the problem.
 

·
Registered
Joined
·
152 Posts
Discussion Starter #6
yo thanks eagle sport i will try that and tell yall what happens.
 

·
Registered
Joined
·
861 Posts
Also take a multimeter and make sure the fuseable link is not blown from the ALT to the end if the wire. The car will run as long as the batt has a little juice then quit that is why I think it is the wire. Also make sure the ground wire is not corroded. I always put a min of 4gage wire from the motor to the firewall.
 

·
Registered
Joined
·
372 Posts
it sounds more like an alt. or a bad wire feed to the battery when you have the car on put voltmeter to back of alt. to see voltage and make sure it matches at battery if it doesnt replace wire
 

·
Registered
Joined
·
152 Posts
Discussion Starter #9
when the guy tested the alt could the machine make a mistake? I have not tested the wires yet because i dont really know how. But i plan on doing that and taking it to get the battery and alter tested. Thanks for the help.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top