Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
I got mine a few weeks ago and it was a pretty good buy. Got my mpg higher coz of the Performance tune. I got a new mod on my car recently so I ordered new tunes from Bama, they emailed me the new tunes and how to upload em on your device. Followed the procedure but when I open the SCT Device Updater, it can't detect my X4. It just says "Can't find device". Not really sure what's wrong.
 

·
Registered
Joined
·
25 Posts
I also have this tuner and was wondering the same thing
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
I asked a couple of people too and they have the same problem with the driver/updater :angry12.gif
 

·
Registered
Joined
·
4,254 Posts
I got mine a few weeks ago and it was a pretty good buy. Got my mpg higher coz of the Performance tune. I got a new mod on my car recently so I ordered new tunes from Bama, they emailed me the new tunes and how to upload em on your device. Followed the procedure but when I open the SCT Device Updater, it can't detect my X4. It just says "Can't find device". Not really sure what's wrong.
I'm glad to hear you're enjoying the current tune on your Mustang. We can definitely work with you here to make sure that your device get's fixed. Between the Bama team and SCT directly you'll be squared away in no time!

Can you just give the Bama team a call and they'll help you troubleshoot? We won't leave you hanging so definitely work with them! Our Bama Performance tuning specialists are here in the building Monday-Friday from 9AM-5:30PM EST and Saturday 9AM-5:30PM EST. You can hit them up directly at 888.226.9764 and they'll get you squared away!

I hope this helps! Let me know if you have any questions or need some assistance in the near future.

-Dan
 
1 - 4 of 4 Posts
Top