Ford Mustang Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
1,059 Posts
Discussion Starter #1
Been contemplating the GT500 fuel pumps over the KB BAP. Seems like a fair bit of AFMers are against using one. I think they have changed my mind about the BAP...and am now gonna order the GT500 pumps. Can anyone say anything good about the BAP??? I know Tillmans thinks its a good reliable product. Anyone wanna back them up here??
 

·
Registered
Joined
·
710 Posts
I'm running it. It resolved my fuel pressure recovery time after my N20 engages. I recommend it. Also Shelby uses it on their Super Snakes.

Been contemplating the GT500 fuel pumps over the KB BAP. Seems like a fair bit of AFMers are against using one. I think they have changed my mind about the BAP...and am now gonna order the GT500 pumps. Can anyone say anything good about the BAP??? I know Tillmans thinks its a good reliable product. Anyone wanna back them up here??
 

·
Registered
Joined
·
382 Posts
The BAP is running fine for me. If you are looking to go 600 hp plus, you may want to consider going to GT500 pump setup with a BAP.
 

·
Registered
Joined
·
1,059 Posts
Discussion Starter #4
I thought you wouldnt need the bap if you had the gt500 pumps??
 

·
Registered
Joined
·
188 Posts
I've been running a BAP for 2-1/2 years with no problems.
 
B
Joined
·
0 Posts
Just watch out for the GT500 wiring harness. A lot of them are bad and Ford refuses to recall them. I believe the new wiring harness has a strand of Ford blue woven into them. My original harness was bad and Ford didn't want to cover the cost of a new one until they had the opportunity to test the original harness to determine it was defective.
 

·
Registered
Joined
·
519 Posts
I thought you wouldnt need the bap if you had the gt500 pumps??
You do if you want to go above about 660 hp.. the GT500 dual pumps with the dual BAP gives you enough fuel for about 1000 hp..
 

·
Premium Member
Joined
·
72,882 Posts
Just watch out for the GT500 wiring harness. A lot of them are bad and Ford refuses to recall them. I believe the new wiring harness has a strand of Ford blue woven into them. My original harness was bad and Ford didn't want to cover the cost of a new one until they had the opportunity to test the original harness to determine it was defective.
What symptoms did you have?
 

·
Premium Member
Joined
·
72,882 Posts
The car fired up and would idle but as soon as you touched the throttle it would cut out and want to shut down, catch itself and come back to idle. It had no fuel pressure.
Interesting... Well I don't have that issue. Did they replace the entire harness, FPDM and all?
 
B
Joined
·
0 Posts
Interesting... Well I don't have that issue. Did they replace the entire harness, FPDM and all?

....seems like that must be a first for you from what I have read. Aren't most these cars full of issues once you really start modding them anyway? I know mine is. I still have a fuel/ignition problem, driveshaft vibrations, cold start....etc
 

·
Premium Member
Joined
·
72,882 Posts
....seems like that must be a first for you from what I have read. Aren't most these cars full of issues once you really start modding them anyway? I know mine is. I still have a fuel/ignition problem, driveshaft vibrations, cold start....etc
I think it's the only issue I haven't had. :so
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top