Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Hey guys I just put a new wiring harness (under dash and engine bay) in my 67 coupe. Every time I put on the left blinker my dome light flashes. And when I open my door the brake light goes on. I checked over the wiring and it looks good... Any ideas?
Thanks
Dan
 

·
Registered
Joined
·
131 Posts
Check the grounds, too. I've had bad grounds do stuff like make the dash lights blink with the turn signal.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
Hi there just checked the grounds they seem to be good. However i was looking at one of the plugs (the green one that goes to tail light feed) and it seems like the wiring is backwards. The colours on the wires don't line up on either side of the plug? And when i move the plug the dome light seems to stop blinking for a second. I cant even find the plug on this diagram. Maybe 14401 assembly?
http://hammar.dyndns.org/~djhamma/wiring/1967/67exter1.jpg
Sorry not so good with electrical.
Dan
 

·
Registered
Joined
·
831 Posts
When your courtesy light circuit is energized via you opening the door, there is voltage reaching the brake light circuit. The turn signal is just the brake light flashing. And when you use the turn signal, the courtesy light circuit is energized. I realize I am not telling you anything you don't know, I am just laying it all out.

You are going to have to play detective. There is no way for anyone to diagnose what has happened except with generalities like "You have plugged something in wrong somewhere". You are going to have to trace the brake light circuit and the courtesy light circuit and see where they meet. They should meet only at the headlight switch. Since your left brake light is affected, odds are the wire cross is on the left side of the vehicle (in terms of electrical circuits, not necessarily in location).

Sorry this post is so general, but as I said, that is the only help that we can give via the Internet. :(
 

·
Registered
Joined
·
2,624 Posts
Can you take a photo of the plug in question Dan?
 

·
Registered
Joined
·
1,063 Posts
Hey guys I just put a new wiring harness (under dash and engine bay) in my 67 coupe. Every time I put on the left blinker my dome light flashes. And when I open my door the brake light goes on. I checked over the wiring and it looks good... Any ideas?
Thanks
Dan

easy fix...whenever you need to use brakes, open your door! That way people behind you know you are stopping, right :yup:
 

·
Registered
Joined
·
831 Posts
Hi there just checked the grounds they seem to be good. However i was looking at one of the plugs (the green one that goes to tail light feed) and it seems like the wiring is backwards. The colours on the wires don't line up on either side of the plug? And when i move the plug the dome light seems to stop blinking for a second. I cant even find the plug on this diagram. Maybe 14401 assembly?
http://hammar.dyndns.org/~djhamma/wiring/1967/67exter1.jpg
Sorry not so good with electrical.
Dan
This could be the smoking gun. Trace each wire. If the wire meant for the brake light ends up at the dome light, you have found the problem. :)
 
1 - 7 of 7 Posts
Top