Ford Mustang Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
ok so do i was out wit a friend and i got my car rolling a little and hit the throttle wide open and it revved up but like bogged back down the power went to wheels can some help please?
 

·
Registered
Joined
·
398 Posts
not sure what you are asking friend.......sentence doesn't really explain anything..........




hotwheels of insanemustangs.com
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
hey sorry im just trying to figure out why the car is doing this what happened was i was rolling just a little bit and nailed the throttle and it revved like it was about to just take off but before power had a chance to go to the wheels the car like bogged then revved back up and started going is that anybetter?:confused:
 

·
Registered
Joined
·
150 Posts
im not positive but im gonna take a guess and say a fuel problem :shrug
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
any chance it could be the tps?
 

·
Registered
Joined
·
122 Posts
check your MAF, and clean with brake clean and allow to dry well if there is any dirt on it at all.

or (not to call you dumb but) is it a manual trans, are you sure you shifted correctly?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 ·
yes its manual and i was in first rolling just enough where i was off the clutch completely and just on the gas and i hit the throttle wide open hoping maybe to squeak them a little just them take off and it never even had a chance to get the power to the wheels before it went down and back up :confused: ill have to see a again and maybe i was on the clutch a little still and then let off dont think so though i only been driving this car for a few weeks now so i may have screwed up but i dont think so because it did it twice not just once
 

·
Registered
Joined
·
122 Posts
well then check your maf, bogging down like that is characteristic of a dirty maf, and one more thing. disconnect the battery for about 15 mins to reset the barometer and then take it out and goose it to bring the barometer reading up
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
ok thanks everyone for your help
 

·
Registered
Joined
·
273 Posts
hey man i have the same problem on my car amd o still havent solved it put ill let u know wut it is i think its fuel problem. I clean my MAF but i didnt reset it so idk
 

·
Registered
Joined
·
4,809 Posts
He isnt using platinum plugs right?
 

·
Registered
Joined
·
273 Posts
check ur fuel pump to see if u have any crap in the filter ,thats wut happend to me it was bogging and not getting any power.Changed the pump and fuel pump relay and everthing is working fine.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top