Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
528 Posts
Discussion Starter #1
Starting 2 weeks ago I was on my way home in 80% + weather. Was a lot of stop and go traffic. I noticed when I got about half way home the temp needle starting slowly raising towards the A in NORMAL when it has ALWAYS stood straight up on the R. It seemed to stay up there until I got to my location and turned the car off.

Didnt seem to happen for a few days.

Did the same thing yesterday on the way home. I got worried and cranked the heat which caused the needle to quickly drop back to normal.

This morning (it was cooler out) on my way to work I took all highway and the needle was fine until getting off the highway and hitting my first traffic light. The second I was idling, the needle starting raising from staight up to the hotter side again. Only when I cranked the heat did the needle drop to normal again.

The water pump was replaced about 8 months ago.
There are no leaks as it is holding all it's coolant.
The coolant is cloudy and has black tint to it, but still green.
The thermostat was replaced about 2 years ago.


Dont know. Bad thermostat?
 

·
Registered
Joined
·
9 Posts
It is possible that there is air the system which makes the system run hot. This is a problem I have had in the past. A sticking thermostat could also be the culprit.
 

·
Registered
Joined
·
2,146 Posts
take the thermostat out and boil it in water on the stove, then you can see it it opens or not. other than that check your gaskets, sometimes when the intake manifold gaskets start going bad it does that when the car idles.
 

·
Registered
Joined
·
528 Posts
Discussion Starter #4
I dont know, but it got worse today on the way home. Temps here are about 100%....car comes to operating temp (needle standing straight up)......stays there for about 10 minutes and then starts its raise.

Today (even after blasting the heat) the needle would not come back down.....stuck up at the A in NORMAL.

Appears to start raising once I start stopping alot.

Checked the upper hose to find it HOT

Checked the lower hose to find it JUST AS HOT.

Wondering if the radiator went??????????????

PLEASE HELP
 
1 - 4 of 4 Posts
Top